Opened 4 years ago

Closed 2 years ago

#7085 closed defect (fixed)

Neverhood Russian version bug (BlbArchive::load() Error during decompression)

Reported by: SF/ilya13 Owned by: sev-
Priority: blocker Component: Engine: Neverhood
Keywords: has-save-game Cc:
Game: The Neverhood

Description (last modified by csnover)

1.8.0 and 1.9.0-git (On 1.7.0 game completable, but slow animation with OpenGL aspect ratio)
GNU/Linux x86_64
Russian "НЕВЕРьвХУДо" ("Дядушка Рисёч")

Check all 3 checkboxes in tab "Engine".
Selected graphic "OpenGL" and check all 2 checkboxes "Full screen" and "Aspect ratio"
Load game from save or complete aqua quest and try enter to house with TV-set near of fountan.

It appears console with an error message and after print "exit" the game crush.

[2016-03-25 07:35:12] ScummVM 1.9.0git1368-g60b763b (Mar 25 2016 05:05:54)
[2016-03-25 07:35:12] Vorbis FLAC ALSA SEQ TiMidity RGB zLib FluidSynth FreeType2 JPEG PNG
[2016-03-25 07:35:12] --- Log opened.
[2016-03-25 07:35:39] WARNING: DCL-INFLATE Error: Inconsistent bytes written (114762) and target buffer size (131776)!
[2016-03-25 07:35:39] BlbArchive::load() Error during decompression of 58208810 (offset: 46010519, disk size: 24852, size: 131776)!
[2016-03-25 07:35:47] --- Log closed successfully.

On 1.7.0 is not a bug, but the game is slow with OpenGL, Full screen, Aspect ratio.

Ticket imported from: bugs/7085.

Attachments (1)

neverhood-win-ru.000 (24.5 KB ) - added by SF/ilya13 4 years ago.

Download all attachments as: .zip

Change History (5)

by SF/ilya13, 4 years ago

Attachment: neverhood-win-ru.000 added

comment:1 by csnover, 2 years ago

Priority: highblocker

Raising all identified crasher, hang, and memory violation bugs which I could not fully triage myself to blocker priority for the next release.

comment:2 by csnover, 2 years ago

Keywords: has-save-game added

comment:3 by csnover, 2 years ago

Description: modified (diff)

comment:4 by sev-, 2 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

Fixed in 11d28ab

Note: See TracTickets for help on using tickets.