Opened 3 years ago

Closed 3 years ago

#7084 closed defect (fixed)

SHERLOCK: Crash when taking inventory

Reported by: SF/ignalina Owned by: eriktorbjorn
Priority: normal Component: Engine: Sherlock
Keywords: Cc:
Game: Sherlock Holmes: Case of the Rose Tattoo

Description

ScummVM 1.9.0git1303-g8161eff (Mar 23 2016 22:43:40)
Features compiled in: TAINTED Vorbis FLAC MP3 SEQ TiMidity RGB zLib MPEG2 FluidSynth Theora AAC FreeType2 JPEG PNG

The Case of the Rose Tattoo (English, DOS CD) crashes when right-clicking anywhere for contextual menu, then selecting Inventory.

Assertion failed: (isValidRect()), function Rect, file ./common/rect.h, line 100.

OS X 10.11.4

Ticket imported from: bugs/7084.

Change History (2)

comment:1 Changed 3 years ago by eriktorbjorn

This was part regression since it worked until recently, part bug since it was trying to draw the wrong line in the inventory dialog. Thanks to dreammaster for figuring out the appropriate fix, while I was still scratching my head and trying to figure out what it was trying to do.

comment:2 Changed 3 years ago by eriktorbjorn

Component: Engine: Sherlock
Game: Sherlock Holmes: Case of the Rose Tattoo
Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.