Opened 5 years ago

Closed 8 months ago

Last modified 8 months ago

#7075 closed defect (outdated)

SCI: Music does not play correctly.

Reported by: SF/cyriller Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: midi Cc:
Game: Space Quest 5

Description

The musics in SCI games don't play correctly. Some intruments stop too soon. It happens in every sci games (SQ5 - SQ6 - Gabriel knight etc...)

Ticket imported from: bugs/7075.

Change History (10)

comment:1 by m-kiewitz, 5 years ago

Can you please tell us which output device you used? AdLib emulator? MT-32 emulation? MIDI? Real MT-32?

Which ScummVM version? Which platform you are on?

btw. Space Quest 6 + Gabriel Knight are not supported at the moment.

comment:2 by SF/cyriller, 5 years ago

Use adlib emulator and Midi.

I use Scummvm 1.9.0git1091 -gea81d21 (14 march) I am on windows 7 64 bits

I know SQ6 and GK are not supported but it seems this problem affects every SCi games for me. I played with SQ4 and I think I have the same problem. I tested the MT-32 emulator and the sound is better but some games are not decigned for it.

comment:3 by m-kiewitz, 5 years ago

Can you please try the official ScummVM 1.8 as well? Also which instruments are not working properly? I just listened a bit to the SQ4 intro and didn't hear any issues.

comment:4 by SF/cyriller, 5 years ago

I try the official ScummVM 1.8 and i have the same issue. It's difficult to find the instruments but the " tings" in sierra's logo stop too early (when the logo shines) and the music in aptitude test in SQ5 is really bad with midi devices. it works great with dosbox.

comment:5 by m-kiewitz, 5 years ago

Can you switch to DOSBox AdLib emulation? Options -> Audio -> AdLib emulator

I'm not sure, if we currently use MAME as default or DOSBox. Try both.

comment:6 by SF/cyriller, 5 years ago

nothing change...

I juste heard the introduction of SQ5 and the music with midi or OPL adlib dosbox and mame is not correct.

comment:7 by lordhoto, 5 years ago

Summary: Music does not play correctly in SCI games.SCI: Music does not play correctly.

comment:8 by csnover, 3 years ago

Keywords: midi added
Owner: changed from m-kiewitz to csnover

comment:9 by digitall, 2 years ago

Owner: csnover removed

comment:10 by sluicebox, 8 months ago

Owner: set to sluicebox
Resolution: outdated
Status: newclosed

I'm closing this bug report simply on the grounds of it being poorly written.

"Some instruments stop too soon"? Which ones? When? The SQ5 intro is several minutes long, literally anything to narrow it down would have been more helpful than this. It sounds fine to me, maybe because four years have passed and the problem has been fixed, maybe because I don't have a discriminating ear to evaluate every single instrument. Again, literally any piece of specific information would have helped.

I see a lot of people's time wasted in this bug report history and nobody being able to confirm that there was a bug in the first place. (Which there probably was!)

If you're reading this, please learn from it.

Last edited 8 months ago by sluicebox (previous) (diff)
Note: See TracTickets for help on using tickets.