Opened 4 years ago

Closed 4 years ago

#7062 closed defect (fixed)

BS25: Background animation freeze and lost game screen

Reported by: raziel- Owned by: sev-
Priority: normal Component: Engine: Sword25
Keywords: Cc:
Game: Broken Sword 2.5

Description

ScummVM 1.9.0git (Feb 26 2016 17:10:52)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG

I've got a mean glitch which breaks the game graphics.

Steps to reproduce:
1) In the main menu click on "Credits" and let them roll

At about when "3D Graphics" scrolls in, the background's "red smoke" animation will freeze to a stop, the credits roll along.
After "Many thanks for the support to" scrolls in the animation starts again but only in a "2-bit" fashion (only two animation frames are displayed over and over again)
After the credits reached the end, they will just sit there and wait for the player to click on the back icon.
As soon as the credits are done scrolling the background animation freezes to a stop again, unless the user moves the mouse around.

2) Click on the back icon

3) In the main menu background animation has come to a full freeze aswell now (sometimes it can be brought to show the "2-bit" animation once the mouse cursor is moved around, but not always.

4) Now start a "New game" and either watch or skip the intro.

5) The game screen will consist of a still picture of the former "red smoke" background (but without the animation), music and speech will run fine, but no game screen will be visible et al, no sprite drawing either.
Scene transitions will fade out and fade in, but only to bring up that still "red smoke" screen, unable to play the game.

I'll attach a screenshot which can be compared to another bug item and shows that the game logic (and least for hotspots) is still there, but the game screen is never drawn.
See here for comparision:
https://sourceforge.net/p/scummvm/bugs/7061/

Screenshot shows the scene in front of Nico's apartment and i can even trigger the mouse icon bug from the above mentioned item (see screenshot)

Broken Sword 2.5: The Return of the Templars (English)

AmigaOS4 - PPC - SDL - BE
gcc (adtools build 5.3.0) 5.3.0

Ticket imported from: bugs/7062.

Attachments (1)

Broken Sword IIV-Broken Mouse Icon on Broken Scene.png (379.0 KB ) - added by raziel- 4 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 by raziel-, 4 years ago

Should have looked at the already open bug items, sorry.

Related (or even duplicate of) https://sourceforge.net/p/scummvm/bugs/6978/

comment:2 by sev-, 4 years ago

Fixed.

comment:3 by sev-, 4 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.