Opened 4 years ago

Closed 7 months ago

#7059 closed defect (fixed)

SCI: PHARKAS Mac crashes while trying to select shovel item from inventory

Reported by: SF/eisnerguy1 Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: has-pull-request Cc:
Game: Freddy Pharkas: Frontier Pharmacist

Description

Freddy Pharkas: Frontier Pharmacist (Macintosh/English)
Tried in:
ScummVM 1.8.0pre-dirty (Feb 24 2016 18:45:42) (compiled from 1.8.0 branch, commit 1309446500e358514ed8fdf5ff6e91da31b5fb69)
ScummVM 1.8.0pre-dirty (Feb 24 2016 18:45:42) (compiled from 1.8.0 branch, commit a2dd7392694dfcc5da7f1a2e19317ffe92d4fa7c)
* ScummVM 1.8.0pre198-ga2dd739 (Feb 25 2016 04:39:18)
Mac OS X 10.10.5

At a point during Act III, you need to go to the graveyard, grab a shovel a dig up a grave to get a safe deposit box key (in order to retrieve your guns from the safe deposit box at the bank). I've attached a video of what happens in ScummVM. It freezes and then crashes if I try to select the shovel item from the inventory.

I also ran it in Terminal (while using my custom scummvm game wrapper, the 2 pre-dirty builds listed above), and I’ve included the output below. Everything up until the last “WARNING: Unhandled kMacPlatform(2)!” line is before I try selecting the shovel from my inventory.

Using configuration file: ../Resources/scummvm-fpfp.ini
User picked target 'freddypharkas-mac' (gameid 'sci')...
  Looking for a plugin supporting this gameid... SCI [SCI0, SCI01, SCI10, SCI11]
  Starting 'Sierra SCI Game'
WARNING: Unhandled kMacPlatform(3)!
WARNING: Unhandled kMacPlatform(2)!
WARNING: Unhandled kMacPlatform(2)!
WARNING: Unknown PICT opcode 0090!
WARNING: Unknown PICT opcode 8006!
WARNING: Unknown PICT opcode 000e!
WARNING: Unknown PICT opcode 0005!
WARNING: Unknown PICT opcode 0048!
WARNING: Unknown PICT opcode 0048!
WARNING: Unknown PICT opcode 0008!
WARNING: Unknown PICT opcode 004a!
WARNING: Unknown PICT opcode 17cd!
WARNING: Unknown PICT opcode 0050!
WARNING: Unknown PICT opcode ffff!
WARNING: Unknown PICT opcode ffff!
WARNING: Unknown PICT opcode ffff!
Assertion failed: (_pos <= _size), function seek, file common/stream.cpp, line 77.
/Users/eisnerguy1/SheepShaver/Freddy/scumm/Freddy Pharkas Frontier Pharmacist_1.8.0pre.app/Contents/MacOS/launchb2: line 4: 83199 Abort trap: 6           ./scummvm -c "../Resources/scummvm-fpfp.ini" -p "../Resources/game" --savepath="../Resources/Saves" freddypharkas-mac 

And here's the similar output while running ScummVM (the 1.8.0pre198-ga2dd739 build listed above) from the Terminal:

User picked target 'freddypharkas-mac' (gameid 'sci')...
  Looking for a plugin supporting this gameid... SCI [SCI0, SCI01, SCI10, SCI11]
  Starting 'Sierra SCI Game'
WARNING: Unhandled kMacPlatform(3)!
WARNING: Unhandled kMacPlatform(2)!
WARNING: Unhandled kMacPlatform(2)!
WARNING: Unknown PICT opcode 0090!
WARNING: Unknown PICT opcode 8006!
WARNING: Unknown PICT opcode 000e!
WARNING: Unknown PICT opcode 0005!
WARNING: Unknown PICT opcode 0048!
WARNING: Unknown PICT opcode 0048!
WARNING: Unknown PICT opcode 0008!
WARNING: Unknown PICT opcode 004a!
WARNING: Unknown PICT opcode 17cd!
WARNING: Unknown PICT opcode 0050!
WARNING: Unknown PICT opcode ffff!
WARNING: Unknown PICT opcode ffff!
WARNING: Unknown PICT opcode ffff!
../../src-stable/src/common/stream.cpp:77: failed assertion `_pos <= _size'
Abort trap: 6

I would have recorded what happens in the native Mac version (while playing it in SheepShaver) but, the game freezes consistently in 1 spot in Act II so, here’s what happens in the DOS CD version:

https://youtu.be/TDr2mo5qMto?t=39m38s

Ticket imported from: bugs/7059.

Attachments (2)

Shovel.mov (10.3 MB ) - added by SF/eisnerguy1 4 years ago.
freddypharkas-mac.008 (55.9 KB ) - added by SF/eisnerguy1 4 years ago.

Change History (12)

by SF/eisnerguy1, 4 years ago

Attachment: Shovel.mov added

comment:1 by lordhoto, 4 years ago

Can you please attach a save at this place so one can try to reproduce this easily?

This looks like you might have broken data files, did you try to copy over the files from your floppies again (and check if you got any errors)?

by SF/eisnerguy1, 4 years ago

Attachment: freddypharkas-mac.008 added

comment:2 by SF/eisnerguy1, 4 years ago

Woops, sorry, forgot to attach a save file before. The save file I've attached has Freddy standing near the shovel.

If that's the case, then why could I pick up the shovel and scummvm only crashes when trying to select it from the inventory?

To be honest, since it isn't for sale anywhere (and the Mac version is kinda rare), I got the files from Macintosh Garden awhile back. I did buy the Mac version on eBay yesterday and it should be delivered to my house tomorrow. I'll double check the files then.

comment:3 by SF/eisnerguy1, 4 years ago

I just got my copy of the game in the mail. I used the data files from these floppies (and there were no errors in them). I got the same result as when I used the files I got from Macintosh Garden. So, it's a bug in ScummVM, not the game's files.

comment:4 by eisnerguy1, 3 years ago

This still occurs in ScummVM 1.9.0 (Oct 11 2016 19:58:14). Running it on 10.10.5. The same Unknown PICT opcode error messages pop up if you run ScummVM via Terminal.

WARNING: Unknown PICT opcode 0090!
WARNING: Unknown PICT opcode 8006!
WARNING: Unknown PICT opcode 000e!
WARNING: Unknown PICT opcode 0005!
WARNING: Unknown PICT opcode 0048!
WARNING: Unknown PICT opcode 0048!
WARNING: Unknown PICT opcode 0008!
WARNING: Unknown PICT opcode 004a!
WARNING: Unknown PICT opcode 17cd!
WARNING: Unknown PICT opcode 0050!
WARNING: Unknown PICT opcode ffff!
WARNING: Unknown PICT opcode ffff!
WARNING: Unknown PICT opcode ffff!

comment:5 by eisnerguy1, 3 years ago

This still occurs in ScummVM 1.10.0git2888-ga925264 (Mar 27 2017 04:50:05). Running it on Mac OS X 10.12.4. Here's the output in Terminal:

User picked target 'freddypharkas-mac' (gameid 'sci')...

Looking for a plugin supporting this gameid... SCI [SCI0, SCI01, SCI10, SCI11, SCI32]
Starting 'Sierra SCI Game'

WARNING: Unhandled kMacPlatform(3)!
WARNING: Unhandled kMacPlatform(2)!
WARNING: Unhandled kMacPlatform(2)!
WARNING: Unknown PICT opcode 0090!
WARNING: Unknown PICT opcode 8006!
WARNING: Unknown PICT opcode 000e!
WARNING: Unknown PICT opcode 0005!
WARNING: Unknown PICT opcode 0048!
WARNING: Unknown PICT opcode 0048!
WARNING: Unknown PICT opcode 0008!
WARNING: Unknown PICT opcode 004a!
WARNING: Unknown PICT opcode 17cd!
WARNING: Unknown PICT opcode 0050!
WARNING: Unknown PICT opcode ffff!
WARNING: Unknown PICT opcode ffff!
WARNING: Unknown PICT opcode ffff!
../../src-master/src/common/stream.cpp:98: failed assertion `_pos <= _size'
Abort trap: 6

comment:6 by eisnerguy1, 3 years ago

Priority: normalblocker

comment:7 by wjp, 3 years ago

Priority: blockernormal

comment:8 by sluicebox, 7 months ago

Keywords: has-pull-request added
Owner: set to sluicebox

comment:9 by Filippos Karapetis <bluegr@…>, 7 months ago

In b195ff5e:

GRAPHICS: Add support for PICT opcode $90 BitsRect

Add limited support for unpacked PICT bits which FPFP Mac requires.

SCI games use packed PICT bits unless an image is less than 8 bytes
per row in which case they can't be packed, like FPFP's shovel icon.

Fixes bug #7059 which prevents the game from being completed.

comment:10 by sluicebox, 7 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.