Opened 3 years ago

Closed 10 days ago

#7058 closed defect (outdated)

SCI: PHARKAS Mac can't restore from save file

Reported by: SF/eisnerguy1 Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Freddy Pharkas: Frontier Pharmacist

Description

Freddy Pharkas: Frontier Pharmacist (Macintosh/English)
Tried in ScummVM 1.8.0pre-dirty (Feb 24 2016 18:45:42) (compiled from 1.8.0 branch, commit 822d546f7d079e35fedf3523a32d874b031e7b8a)
Mac OS X 10.10.5

So, while using ScummVM to play the Mac version of Freddy Pharkas, I can't restore from a previous save file. When I try to (either from the "Restore" button on the titles screen, or the Control panel), I get an error message in the debug console window. I've attached a screenshot of the output message.

Ticket imported from: bugs/7058.

Attachments (1)

Console_Output.png (16.1 KB) - added by SF/eisnerguy1 3 years ago.

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by SF/eisnerguy1

Attachment: Console_Output.png added

comment:1 Changed 3 years ago by SF/eisnerguy1

The ticket can be closed. I rebuilt my custom ScummVM game wrapper and this issue isn't showing up anymore. Not sure what caused it in the first place but, I'm able to restore my saves again.

comment:2 Changed 3 years ago by lordhoto

Can you please attach the save you tried to load? Can you also explain where in the game you tried to load the game (preferably with a savegame at this place)? Does it now work at the same scene, or did you load from a different scene/place this time where it worked?

comment:3 Changed 3 years ago by wjp

Could you explain what your wrapper does? It's very strange that this crash could be affected by that.

comment:4 Changed 3 years ago by SF/eisnerguy1

It wasn't just a specific save. If I tried selecting "Restore" from the main title screen, I got that message even before it brought me to the screen with the save files on it. Same result happened if I selected "Play" from the main title screen and then selected "Restore" from the control panel screen.

comment:5 Changed 3 years ago by SF/eisnerguy1

Yeah, so, instead of a Mac app first loading the scummvm executible file, it loads an executible called "launchb2". This is what's inside that file:

#!/bin/sh
mypath=`dirname "$0"`
cd "$mypath"
./scummvm -c "../Resources/scummvm-fpfp.ini" -p "../Resources/game" --savepath="../Resources/Saves" freddypharkas-mac

It's based of this simple Basilisk II (runs System 6 & Mac OS 7) wrapper:
http://www.emaculation.com/forum/viewtopic.php?f=6&t=8543

comment:6 Changed 3 years ago by lordhoto

And now restoring from the main title screen and from the control panel screen suddenly work without any other changes since it failed?

comment:7 Changed 3 years ago by SF/eisnerguy1

Yeah, exactly.

comment:8 Changed 10 days ago by sluicebox

Owner: set to sluicebox
Resolution: outdated
Status: newclosed
Summary: SCI: PHARKAS Mac can't restore from save fileSCI: PHARKAS Mac can't restore from save file

I'm closing this. Without a save game file there's no way to know if this three year old report is still an issue or not. I can save and restore with gusto. Re-open and attach a save file if you're able to reproduce and I'll pounce on it like a puma.

Note: See TracTickets for help on using tickets.