Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#7051 closed defect (fixed)

FW: Music stops in CD version when opening bathroom cabinet

Reported by: eriktorbjorn Owned by: Kirben
Priority: normal Component: Engine: Cine
Keywords: Cc:
Game: Future Wars

Description

English CD version of the game, current 1.8 branch of ScummVM.

When opening the bathroom cabinet, near the very beginning of the game, the music stops. This did not happen to me when I tried the same thing in DOSBox.

Unfortunately I can't provide a savegame, because it seems the music isn't resumed when loading a savegame (this appears to be the same behavior as the original), but since it's in the second room of the game it's not hard to reproduce anyway.

Ticket imported from: bugs/7051.

Change History (2)

comment:1 by Kirben, 4 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:2 by Kirben, 4 years ago

The problem was caused by the stopMusic() call in FWScript::o1_playSample().

The original version would only stop the music in that function, if non-CD music was been played, at the same time as the CD music. I really doubt that ever occurs in the game, so I simply disabled the stopMusic() call in FWScript::o1_playSample().

Note: See TracTickets for help on using tickets.