Opened 8 years ago

Closed 6 weeks ago

#7045 closed defect (fixed)

AGI: KQ1 - Graham Facing Away from King after Bowing

Reported by: lordhoto Owned by: sluicebox
Priority: normal Component: Engine: AGI
Version: Keywords:
Cc: Game: King's Quest 1

Description

ScummVM 1.8.0pre133-gb1fff2d (Feb 18 2016 20:28:32) English DOS AGI from King's Quest Collection Linux/amd64 compiled with gcc 5.3.0

After bowing Graham faces away from the King instead of towards him like with the original interpreter (confirmed with DOSBox). Just load the attached save and type "bow" and watch the animation.

I get the following warnings on stderr while Graham bows: WARNING: Non-existant loop requested for screen object 0! WARNING: view 71, requested loop 1 -> clipped to loop 0!

Ticket imported from: bugs/7045.

Attachments (1)

kq1.005 (3.4 KB ) - added by lordhoto 8 years ago.

Download all attachments as: .zip

Change History (4)

by lordhoto, 8 years ago

Attachment: kq1.005 added

comment:1 by m-kiewitz, 8 years ago

I already noticed this one during my KQ1 IIgs playthrough. It already happened in 1.7.0 and it's caused by us fixing bad loops.

KQ1 sets the loop of ego first in this case and the view after that, which triggers our fix up code. I plan on creating a script patcher for AGI too and want to add a script patch for this issue, because it's probably the best solution.

comment:2 by raziel-, 4 years ago

Summary: KQ1AGI: Graham Facing Away from King after BowingAGI: KQ1 - Graham Facing Away from King after Bowing

comment:3 by sluicebox, 6 weeks ago

Owner: changed from m-kiewitz to sluicebox
Resolution: fixed
Status: newclosed

Fixed in: https://github.com/scummvm/scummvm/commit/3d2783c07420e8c56ab92bec0621059e1814ba64

It's just a workaround, but it's simple. It can easily be converted to a script patch later.

Note: See TracTickets for help on using tickets.