Opened 8 years ago

Closed 2 months ago

#7032 closed defect (wontfix)

AGI: Sorceror's Appraisal: Can`t crush skull

Reported by: SF/necros2014 Owned by: sluicebox
Priority: normal Component: Engine: AGI
Version: Keywords: original
Cc: Game: AGI Fanmade

Description

ScummVM 1.9.0git8-g83b3d67 (Feb 7 2016 13:54:07) 64 build win10 64

Ticket imported from: bugs/7032.

Attachments (2)

agi-fanmade-1.001 (2.5 KB ) - added by SF/necros2014 8 years ago.
agi-fanmade-fallback.001 (2.5 KB ) - added by raziel- 4 years ago.
ScummVM2.2.0git save game

Download all attachments as: .zip

Change History (9)

by SF/necros2014, 8 years ago

Attachment: agi-fanmade-1.001 added

comment:1 by m-kiewitz, 8 years ago

Summary: Sorceror`s appraisal, can`t crash skull tells me i didn`t put itAGI: Sorceror`s appraisal, can`t crash skull tells me i didn`t put it

comment:2 by m-kiewitz, 8 years ago

Does this work in the original interpreter?

comment:3 by SF/necros2014, 8 years ago

hmm, i guess its games bug cause when i exit screen and come back skull is gone from altar 8-)

comment:4 by digitall, 6 years ago

Game is freeware fanmade and can be found here:
http://www.realityonthenorm.info/game.php?id=115

Will do a basic check and see if this is still occuring in the current git master...

comment:5 by digitall, 6 years ago

Hmm... I have found two variants of this game. Both have walkthroughs, but they are a bit vague if you are not familar with the game, so having trouble working on the replications steps when starting from the savegame. Might have to play the game through to see...

by raziel-, 4 years ago

Attachment: agi-fanmade-fallback.001 added

ScummVM2.2.0git save game

comment:6 by raziel-, 4 years ago

ScummVM 2.2.0git (Jul 15 2020 10:24:49)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC A/52 FreeType2 FriBiDi JPEG PNG cloud (servers, local)

I can not confirm this issue with above version of ScummVM.

OP didn't really specify the steps to make the issue appear.
Also, OP's save state is from the beginning of a lot of walking and gathering stuff before reaching the altar (and the issue), so any combination of steps to trigger the issue is possible.

I wasn't able to.

Game taken from here: http://www.realityonthenorm.info/game.php?id=115
Solution also taken from there.

Save game from the altar scene attached.

AmigaOS4 - PPC - BE - SDL

comment:7 by sluicebox, 2 months ago

Keywords: original added
Owner: set to sluicebox
Resolution: wontfix
Status: newclosed
Summary: AGI: Sorceror`s appraisal, can`t crash skull tells me i didn`t put itAGI: Sorceror's Appraisal: Can`t crush skull

As the OP said, this is a bug in the original game. You're supposed to put the skull on the altar and then crush it. If put the skull on the altar and then exit the room, the game forgets and doesn't redraw the skull when you return. You can no longer crush it, and you get the message the OP described.

I believe the OP was explaining that they figured this out in their second post. This bug does occur in ScummVM, but that's because it's a fan game script bug. Closing as original behavior.

Note: See TracTickets for help on using tickets.