Opened 3 years ago

Last modified 3 years ago

#7027 new defect

ZGI: Mass Add picks wrong directory to add

Reported by: SF/powersliderr1 Owned by:
Priority: normal Component: Engine: ZVision
Keywords: Cc:
Game: Zork Grand Inquisitor

Description

ScummVM version 1.9.0git8-g83b3d67

Bug happen upon attempting to start the game. This happens immediately at start i see the zork mouse cursor then hard crash to windows,. See attached file for output console.The TGA are located in the folder thus are not missing.

Language: English
Version: GoG
Platform Win32/64

Ticket imported from: bugs/7027.

Attachments (2)

ZGI.png (18.3 KB) - added by SF/powersliderr1 3 years ago.
scummvm.ini (10.0 KB) - added by SF/powersliderr1 3 years ago.

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by SF/powersliderr1

Attachment: ZGI.png added

comment:1 Changed 3 years ago by SF/powersliderr1

Attachment

comment:2 Changed 3 years ago by eriktorbjorn

One possibility is that the files aren't arranged the way the game engine expects them to be. At least in the version I have, it appears to look at the file inquis.zix, which is a text file listing the folders and indicating where the data files are.

I don't have the GOG version of the game, though. I thought I heard that it should work without any rearranging of the files, but...

comment:3 Changed 3 years ago by SF/powersliderr1

I have tried to see if there was a listing of file arrangement and the file
it is looking for is global so it is in both asset folders...

On Thu, Feb 11, 2016 at 3:23 PM, "Torbjörn Andersson" eriktorbjorn@users.sf.net wrote:

One possibility is that the files aren't arranged the way the game engine
expects them to be. At least in the version I have, it appears to look at
the file inquis.zix, which is a text file listing the folders and
indicating where the data files are.

I don't have the GOG version of the game, though. I thought I heard that
it should work without any rearranging of the files, but...


Status: open
Group: Zork Grand Inquisitor
Created: Thu Feb 11, 2016 12:02 AM UTC by Kasey Norman
Last Updated: Thu Feb 11, 2016 12:03 AM UTC
Owner: nobody

ScummVM version 1.9.0git8-g83b3d67

Bug happen upon attempting to start the game. This happens immediately at
start i see the zork mouse cursor then hard crash to windows,. See attached
file for output console.The TGA are located in the folder thus are not
missing.

Language: English
Version: GoG
Platform Win32/64


Sent from sourceforge.net because you indicated interest in
https://sourceforge.net/p/scummvm/bugs/7027/

To unsubscribe from further messages, please visit
https://sourceforge.net/auth/subscriptions/

comment:4 Changed 3 years ago by wjp

This is working fine for me with the GOG version. Could you attach your scummvm config file?

Changed 3 years ago by SF/powersliderr1

Attachment: scummvm.ini added

comment:5 Changed 3 years ago by SF/powersliderr1

conifg file.

comment:6 Changed 3 years ago by SF/powersliderr1

Okay Looking at the conifg file it looks like The mass add tool in scummVm pointed to the ZGI folder inside of the Zork Grand Inquistor folder for some reason... As after I altered that it indeed worked. So looks like the Mass add tool isn't adding the right start folder point.

comment:7 Changed 3 years ago by wjp

Summary: ZGI Crash upon start.ZGI: Mass Add picks wrong directory to add
Note: See TracTickets for help on using tickets.