Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#6995 closed defect (fixed)

LAB: ShowDiff music does not play properly

Reported by: SF/philsalv Owned by: Strangerke
Priority: normal Component: Engine: Lab
Keywords: Cc:
Game: Labyrinth of Time

Description

Occasionally, The Labyrinth of Time will attempt to play sound/music using a ShowDiff action rather than PlaySound or PlaySoundLooping. The DOS and Windows re-release versions handled ShowDiff by pausing the game for the duration of the sound.

The ScummVM implementation does not pause the game, ending the sounds as soon as any on-screen animations are finished.

For an example, see Scene 9. Pulling the toilet chain should play a flushing sound, which now cuts off as soon as the chain animation is finished. Hitting the toilet with a sword should produce a clanging noise, but since there is no animatoin, it does not play at all.

Save file attached is Scene 9 from the Windows re-release. The toilet chain can be moved, and the sword is in the inventory for hitting the toilet.

Reproduced in ScummVM 1.8.0git6220-g792ae03 (Jan 23 2016 05:15:05), Win32

Ticket imported from: bugs/6995.

Attachments (1)

lab-win.000 (15.0 KB) - added by SF/philsalv 22 months ago.

Download all attachments as: .zip

Change History (6)

Changed 22 months ago by SF/philsalv

Attachment: lab-win.000 added

comment:1 Changed 22 months ago by Strangerke

I have added some code to wait for the end of the sound effect before finishing a diff. It's fixing the toilet behavior. It'll be available in the next nightly built.

comment:2 Changed 22 months ago by Strangerke

Owner: set to Strangerke
Resolution: fixed

comment:3 Changed 22 months ago by SF/philsalv

Toilet, sword, and other instances all work in 1.8.0git6246-g75d1385 (Jan 25 2016 05:14:45), Win32.

comment:4 Changed 22 months ago by Strangerke

Status: newclosed

comment:5 Changed 22 months ago by Strangerke

Thanks for the feedback! Closing it.

Note: See TracTickets for help on using tickets.