Opened 4 years ago

Closed 4 years ago

#6992 closed defect (fixed)

LAB: DOS version filename character limit errors

Reported by: SF/philsalv Owned by: Strangerke
Priority: normal Component: Engine: Lab
Keywords: Cc:
Game: Labyrinth of Time

Description

Two filenames in the Windows re-release version of The Labyrinth of TIme are over 8 characters long. The DOS version filenames are shorter and are not loaded properly:

Scene 72: Examining the tile puzzle solution (while facing west) calls SPICT/TILESOLUTION.
The DOS version file is SPICT/TILESOLU (or PICT/TILESOLU for low-resolution DOS version).

The Revolver Springs newspaper image calls SPICT/NEWSPAPER.pic.
The DOS version file is SPICT/NEWSPAPE.pic (or PICT/NEWSPAPE.pic for low-resolution DOS version).

Save files attached for viewing both of these.

Reproduced in ScummVM 1.8.0git6220-g792ae03 (Jan 23 2016 05:15:05), Win32

Ticket imported from: bugs/6992.

Attachments (3)

lab.001 (16.7 KB ) - added by SF/philsalv 4 years ago.
lab.002 (17.8 KB ) - added by SF/philsalv 4 years ago.
newspapercrash.png (54.5 KB ) - added by SF/philsalv 4 years ago.

Download all attachments as: .zip

Change History (10)

by SF/philsalv, 4 years ago

Attachment: lab.002 added

comment:1 by SF/philsalv, 4 years ago

Should have mentioned: these save files are from the DOS version of the game, if it matters.

comment:2 by Strangerke, 4 years ago

Owner: set to Strangerke
Resolution: fixed

comment:3 by Strangerke, 4 years ago

Fixed and verified with your savegames. Could you please test it too?

by SF/philsalv, 4 years ago

Attachment: newspapercrash.png added

comment:4 by SF/philsalv, 4 years ago

TILESOLU seems to be fixed, but still crashing with the newspaper. Game is still trying to open NEWSPAPER.pic rather than NEWSPAPE.pic.

Reproduced it with a clean install of the DOS version on a new playthrough, plus using that attached lab.002 save file. Using 1.8.0git6238-ge5e2a8d (Jan 24 2016 05:54:01), Win32

comment:5 by Strangerke, 4 years ago

I forgot to mention you need to wait for the next nighly build to test the fix.

comment:6 by SF/philsalv, 4 years ago

Oops, this is my first time doing this sort of thing, so sorry about the confusion.

Both fixes work in 1.8.0git6246-g75d1385 (Jan 25 2016 05:14:45), Win32.

comment:7 by Strangerke, 4 years ago

Thanks for the feedback! Closing it.

comment:8 by Strangerke, 4 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.