Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#6981 closed defect (fixed)

High CPU usage on one core

Reported by: SF/windlepoons Owned by: sev-
Priority: high Component: Engine: Sword25
Keywords: Cc:
Game: Broken Sword 2.5

Description

When start and play Broken Sword 2.5, one Core (from 4) has permanent high CPU usage.

Game version:?
Today i have download Sword25 from mirror RWTH Aachen via brokensword25.com and install with wine.

ScummVM 1.8.0git5172-g7820bd5 (Dec 7 2015 05:39:16)
OS: Linux siduction 64bit

Here the – short – output from terminal when exit sword25:

WARNING: Resource "/fonts/menu_14pt_fnt.png" was not released.!
WARNING: Resource "/fonts/menu_14pt_fnt.xml" was not released.!
WARNING: Resource "/cursors/exit_ne/0008.png" was not released.!
WARNING: Resource "/cursors/exit_ne/0007.png" was not released.!
WARNING: Resource "/cursors/exit_ne/0006.png" was not released.!
(…)
WARNING: Resource "/rooms/_default/ani/george_walk/0364.swf" was not released.!
WARNING: Resource "/rooms/_default/ani/george_walk/0363.swf" was not released.!
(…)
WARNING: Resource "/rooms/_default/ani/george_walk/frame_missing.swf" was not released.!
WARNING: Resource "/fonts/menu_20pt_fnt.xml" was not released.!
WARNING: Resource "/fonts/menu_30pt_fnt.xml" was not released.!
WARNING: Resource "/fonts/menu_20pt_fnt.png" was not released.!
WARNING: Resource "/fonts/menu_30pt_fnt.png" was not released.!

Ticket imported from: bugs/6981.

Change History (11)

comment:1 Changed 3 years ago by Strangerke

Priority: normalhigh

comment:2 Changed 3 years ago by Strangerke

It would be nice to fix it before the release of 1.8.0. Raising priority.

comment:3 Changed 3 years ago by RichieSams

Windows on latest daily build:
http://i.imgur.com/WQmQuDK.png

I will try linux build in a bit.

comment:4 Changed 3 years ago by SF/windlepoons

I looking now on another task manager under Linux and see ~26% usage for ScummVM/Sword2.5, this is ok.

Sorry for this ticket, you can this closed.

comment:5 Changed 3 years ago by RichieSams

No worries. Thank you for taking the time to confirm. :)

comment:6 Changed 3 years ago by RichieSams

Resolution: fixed
Status: newclosed

comment:7 Changed 3 years ago by SF/paletta

Hi, I subscribed to this issue because I also found the game very lagging and with high CPU usage, and I can confirm it's still so on current git. CPU usage is 100% on a Core Duo on 32 bit Linux when doing just nothing. For comparison Broken Sword 1/2 are around 6-12%, while COMI is about 21% and are perfectly playable.

comment:8 Changed 3 years ago by sev-

Those games ar uncomparable. Both COMI and Broken Swords 1&2 run on 640x480x8bpp, while BS2.5 is a 800x600x16bpp game, which is 3x more data per screen. Also at this moment BS2.5 does not have dirty rectangles implemented, so the redraws are pretty heavy. This is how the original engine was developed, and the graphics pipeline is implemented in the game scripts, so it would be not trivial to change.

Thus, unfrotunately BS2.5 will stay as a resouce-hungry game at this moment.

comment:9 Changed 3 years ago by SF/windlepoons

I testing with another (KSysguard) system monitor, but i think that not good for core…
http://i.imgur.com/XlAfKRk.png

OS: Linux/Siduction 64bit

comment:10 Changed 3 years ago by sev-

Owner: set to sev-

comment:11 Changed 3 years ago by sev-

Fixed it now both in master and in 1.8.0

Note: See TracTickets for help on using tickets.