Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#6955 closed defect (fixed)

BBVS: Crash when using ingame menu's "Quit"

Reported by: raziel- Owned by: wjp
Priority: normal Component: Engine: BBVS
Keywords: Cc:
Game: Beavis & Butthead Virtual Stupidity

Description

ScummVM 1.8.0git (Nov 21 2015 06:56:08)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG

On using the ingame menu to Quit back to the OS i get a reproducable crash of ScummVM.

Attached are two instances, one right after starting the game.
The second one after the game was finished and the credits rolled.

I can't provide stack backtrace, sorry, but it's reproducable every time for me.

Beavis and Butthead in Virtual Stupidity (Windows/English)

AmigaOS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: bugs/6955.

Attachments (2)

Crashlog_scummvm_2015-11-21_09-45-10.txt (34.5 KB) - added by raziel- 4 years ago.
Crashlog_scummvm_2015-11-21_09-40-26.txt (37.1 KB) - added by raziel- 4 years ago.

Download all attachments as: .zip

Change History (16)

Changed 4 years ago by raziel-

Changed 4 years ago by raziel-

comment:1 Changed 4 years ago by raziel-

This crashlog is after the credits rolled

comment:2 Changed 4 years ago by johndoe123

Component: Engine: BBVS
Game: Beavis & Butthead Virtual Stupidity

comment:3 Changed 4 years ago by johndoe123

No clue about this, it exits fine here under Windows 7.
It could be a big-endian issue.
Maybe someone could run this in Valgrind.

comment:4 Changed 4 years ago by raziel-

Valgrinding this would be nice.

Is there anything else i could provide (apart from a bt)?

comment:5 Changed 4 years ago by eriktorbjorn

I don't get any Valgrind warnings when quitting the game from the main menu with the Linux version of ScummVM. (Though I'm running on little-endian.)

comment:6 Changed 4 years ago by johndoe123

Thanks for checking it.
I'll check the code for possible endian issues tomorrow.

comment:7 Changed 3 years ago by sev-

Any update?

comment:8 Changed 3 years ago by wjp

Can you say exactly how you reproduce it? Do you skip intros and/or other movies? Is the in-game menu the scummvm menu, or is there another way to quit?

comment:9 Changed 3 years ago by raziel-

I tried all possible combinations that crashed before and it doesn't anymore.

Was fixed in the process i guess, this can be closed

Thanks a lot :-)

comment:10 Changed 3 years ago by sev-

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:11 Changed 3 years ago by wjp

Were you maybe using the Classic theme when it crashed? I just fixed a memory corruption problem with BBVS in the main menu with the Classic theme.

comment:12 Changed 3 years ago by raziel-

I just tried with a week old build and classic theme.
The crash was back.

With todays build the crash is gone, so yes, that might have been the cause.

Thank you

comment:13 Changed 3 years ago by wjp

Owner: changed from sev- to wjp

comment:14 Changed 3 years ago by wjp

Great, thanks for verifying.

Note: See TracTickets for help on using tickets.