Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#6950 closed defect (fixed)

ScummVM: Failed to start

Reported by: SF/superzanac Owned by: tramboi
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

Daily build for Windows downloaded nearly 22:00 at Minsk time, Symbian - Builded yesterday from fresh sources How reproduce: Run stable version, 1.7.0 for example, select builtin theme in settings, save and exit Run daily build - and one quick closes How solve: from scummvm.ini remove "gui_theme=builtin" and ScummVM starts. Then ScummVM starts with modern theme. If you choose and apply builting theme ScummVM closes again.

Os: Windows(daily build), Symbian - Builded yesterday from fresh sources with GCCE 4.4.1 and GCC 5.2

Log: [2015-11-10 22:44:53] ScummVM 1.8.0git4838-gcf178e3 (Nov 10 2015 09:38:09) [2015-11-10 22:44:53] TAINTED Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC FreeType2 JPEG PNG [2015-11-10 22:44:53] --- Log opened. [2015-11-10 22:44:53] [2015-11-10 22:44:53] File , line 1: [2015-11-10 22:44:53] [2015-11-10 22:44:53] [2015-11-10 22:44:53] Parser error: Parser expecting key start. [2015-11-10 22:44:53] [2015-11-10 22:44:53] WARNING: Failed to load theme 'builtin'! [2015-11-10 22:44:53] [2015-11-10 22:44:53] File , line 1: [2015-11-10 22:44:53] [2015-11-10 22:44:53] [2015-11-10 22:44:53] Parser error: Parser expecting key start. [2015-11-10 22:44:53] [2015-11-10 22:44:53] WARNING: Failed to load theme 'builtin'! [2015-11-10 22:44:53] Failed to load any GUI theme, aborting! [2015-11-10 22:44:53] --- Log closed successfully.

Ticket imported from: bugs/6950.

Attachments (1)

gui-manager.cpp.patch (855 bytes ) - added by SF/superzanac 5 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 by SF/superzanac, 5 years ago

Lokks like this is double-bug: First - look up Second - I expect attempt to find'n'load another theme - Modern theme for example

by SF/superzanac, 5 years ago

Attachment: gui-manager.cpp.patch added

comment:2 by SF/superzanac, 5 years ago

Here patch for gui-manager.cpp - add autoload modern theme if failed

comment:3 by lordhoto, 5 years ago

There definitely shouldn't be a fallback to modern. Builtin is the fallback choice. What should be done is to fix the builtin theme loading.

comment:4 by SF/superzanac, 5 years ago

Okay, accepted fallback to builtin. But best way fallback to another theme and raise critical warning in gui, isn't it? Using hardcoded staff isn't good - dynamic look up is best way. Looks like builtin theme dropped from app. I can't use it. If I choose app closes immediately. Can you say where look for definition builtin theme and how it embedded in app?

comment:5 by tramboi, 5 years ago

Not much to do with themes policy, it's a (in fact two) lower level bugs. This was introduced by https://github.com/scummvm/scummvm/commit/7d58a50c46ecb7001702a696a3c92eb5ab3d0a36 I tried to run a pristine scummvm on a new debian box and had to fix two bugs in: https://github.com/scummvm/scummvm/commit/06d83f148f8167fbe3e7c671a91f69e36decf1fe and https://github.com/scummvm/scummvm/commit/91e6abd3050ed028bab3fd4d1746adb79fe8adcd

As a a QOI improvement/to debug this, I did this one too: https://github.com/scummvm/scummvm/commit/4920b3ab3ef104cc2278ad7e52fe120bde6c7336

comment:6 by wjp, 5 years ago

As LordHoto said, the builtin theme is the fallback. It hasn't been dropped, or removed, it just has a bug at the moment, which we just have to fix. Or maybe it already is fixed.

Have you tried to update to latest git again?

comment:7 by SF/superzanac, 5 years ago

Someone tried actual daily build for windows or Linux? It's important. I go home soon and rebuild app.

comment:8 by lordhoto, 5 years ago

I am not sure how we are supposed to show any error/warning in GUI, when no theme is working. At this point we do not have any GUI.

In theory when switching themes in the GUI it should fallback to the previously selected one in case the newly selected one does not load. But prior to a bug fix by Bertrand (see his comment) trying to load the builtin theme caused an assert to be triggered, thus closing ScummVM.

comment:9 by lordhoto, 5 years ago

I tried it yesterday on a Linux/amd64 build and the builtin theme worked.

comment:10 by SF/superzanac, 5 years ago

Windows and Symbian - bug fixed.

comment:11 by lordhoto, 5 years ago

Owner: set to tramboi
Resolution: fixed
Status: newclosed

comment:12 by digitall, 2 years ago

Component: GUI
Note: See TracTickets for help on using tickets.