Opened 4 years ago

Closed 3 years ago

Last modified 12 months ago

#6947 closed defect (fixed)

Can't type [ in debug console

Reported by: SF/henke37_2 Owned by: digitall
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

When I have the debug console open and try to type [ on my Swedish keyboard I get a popup about the graphics filter instead of the character being typed.

Ticket imported from: bugs/6947.

Change History (10)

comment:1 by eriktorbjorn, 4 years ago

That's odd, it works on my Swedish keyboard. When you say "a popup about the graphics filter", I assume you mean a ScummVM popup, though off-hand I'm not sure what it would look like.

comment:2 by digitall, 4 years ago

@henke37 : Thanks for the bug report, but we can't replicate this yet. Could you please provide some further information? Specifically, the Exact version of Operating System/Platform that you are using i.e. Windows XP SP1 and Exact version of ScummVM by release or source code revision id.

comment:3 by digitall, 4 years ago

Resolution: worksforme
Status: newpending

comment:4 by digitall, 4 years ago

@eriktorbjorn: Can you also try replicating bug #6944 which sounds like it might be related: https://sourceforge.net/p/scummvm/bugs/6944/

If you reply there it is optimal. Thanks.

comment:5 by m-kiewitz, 4 years ago

I can actually reproduce it.

Running Windows XP, Service Pack 3. ScummVM is from 1 week ago or so.

comment:6 by digitall, 4 years ago

mkiewitz: You are referring to this bug and NOT #6944 right?

I have just tried with Linux x86_64 with latest git i.e. b8caa07ddb2e31cdebbbc012adbf11f721a2fd3a . I tried the Debug Console in Dreamweb and this had no issues with '[' or ']'

Could you indicate which engine / game you reproduced this in?

comment:7 by SF/henke37_2, 4 years ago

I can reproduce in dreamweb. But it was in comi that I originally discovered it.

comment:8 by digitall, 4 years ago

Thanks.. I can try to replicate under WinXP, but I suspect that this requires a non-english keyboard?

@mkiewitz: As you can replicate, can you try to investigate this and see what is going on? Thanks.

comment:9 by sev-, 3 years ago

Owner: set to digitall
Resolution: worksformefixed
Status: pendingclosed

comment:10 by digitall, 12 months ago

Component: GUI
Note: See TracTickets for help on using tickets.