Opened 4 years ago

Closed 4 years ago

#6932 closed defect (fixed)

The Neverhood - Rail car exit screen bug

Reported by: SF/runkz Owned by: eriktorbjorn
Priority: normal Component: Engine: Neverhood
Keywords: Cc:
Game: The Neverhood

Description

Hi, The video here shows the specific bug: https://www.youtube.com/watch?v=0CDOgGli_K8 Basically you can't exit the area through the downward path, only the left and right paths.

Ticket imported from: bugs/6932.

Attachments (2)

neverhood-win.001 (17.3 KB ) - added by SF/runkz 4 years ago.
neverhood-win.034 (11.2 KB ) - added by eriktorbjorn 4 years ago.

Download all attachments as: .zip

Change History (10)

by SF/runkz, 4 years ago

Attachment: neverhood-win.001 added

comment:1 by eriktorbjorn, 4 years ago

I was able to go down, but if I return back up the car does seem to get a bit confused about how to move. But from your description, it doesn't sound like that's quite the same as your problem...

comment:2 by eriktorbjorn, 4 years ago

I think I see what's happening in my "enter from below" case:

It reaches the case in Scene2702::moveCareToPoint() where it calls sendMessage(_asCar, 0x2004, pt.x)

That ends up calling AsCommonCar::handleMessage() in module1600_sprites.cpp, where it uses asPoint() to convert the parameter into a Point. But that means, as far as I can tell, that we just throw away the Y coordinate, by setting it to zero. So presumably it moves as close as it can to that, using only the current track, which is why it moves up.

I can fix that by changing it to sendMessage(_asCar, 0x2004, pt) but if so, should that change also be made in other places?

comment:3 by eriktorbjorn, 4 years ago

Changing it in Scene2706::moveCarToPoint() seems to improve things slightly in that scene as well, but not nearly as much because in this case the track is short, and at the upper part of the screen, so Y coordinate 0 is never far off.

I didn't notice any bad effects from the call in Scene2706::changeTrack().

by eriktorbjorn, 4 years ago

Attachment: neverhood-win.034 added

comment:4 by eriktorbjorn, 4 years ago

I'm attaching a savegame for the Scene2706 glitch, even though I still don't know if this is relevant to this particular bug report. To reproduce that glitch, go down and then click anywhere on the short track leading up and to the right. Even if you click below the car, it will go up.

comment:5 by bluegr, 4 years ago

eriktorbjorn's changes have been merged to master. The changes will be available in the next daily version of ScummVM.

@runkz: Could you please test if your issue is fixed with the next daily version?

comment:6 by digitall, 4 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newpending

comment:7 by digitall, 4 years ago

As the bug submitter has not yet responded, I am moving this to pending-fixed. If he doesn't respond within the next two weeks, we will assume this is fixed and close the bug.

comment:8 by bluegr, 4 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.