Opened 4 years ago

Closed 4 years ago

#6914 closed defect (fixed)

SHERLOCK: Silverbridge residence - dead end

Reported by: SF/mimdoe Owned by: dreammaster
Priority: normal Component: Engine: Sherlock
Keywords: Cc:
Game: Sherlock Holmes: Case of the Rose Tattoo

Description

This seems to be dead end - I already have the blackmail note from Silverbridge but not a picture of the boy and I can't go back.

Ticket imported from: bugs/6914.

Attachments (1)

rosetattoo.084 (23.9 KB ) - added by SF/mimdoe 4 years ago.

Download all attachments as: .zip

Change History (8)

by SF/mimdoe, 4 years ago

Attachment: rosetattoo.084 added

comment:1 by dreammaster, 4 years ago

This could be a bug in the original game, unfortunately. It may prove laborious to get up to the point in the original to see for sure; I'll see if anything screams bug when I try the savegame in ScummVM.

comment:2 by SF/mimdoe, 4 years ago

Yes, I suspect that the game has few such original bugs. I remember some players complained about dead ends in this game on net discussions, for example here: http://alturl.com/5vkjv . And please move it to Case of the Rose Tattoo, it is wrongly in Scalpel.

comment:3 by dreammaster, 4 years ago

Game: Sherlock Holmes: Case of the Serrated ScalpelSherlock Holmes: Case of the Rose Tattoo

comment:4 by bluegr, 4 years ago

Summary: Silverbridge residence - dead endSHERLOCK: Silverbridge residence - dead end

comment:5 by eriktorbjorn, 4 years ago

One strange thing that's probably unrelated, but I've so far only been able to reproduce it with the savegame in this bug report:

If I look at Watson's journal, the conversation options when talking to Hepplethwaite get corrupted. Perhaps just the texts, and they go back to normal later, but for a little while they look like this for me:

  1. I've been thwarted, Holmes. Only you can help sort this confusion.Is Mr. Silverbridge available?
  2. It's been suggested that terrorists may have ignited the Diogenes.Silverbridge has read the newspapers, I presume.
  3. Good news, Holmes. I'm pleased to report that Mycroft is intermittently conscious.Thank you, Hepplethwaite. Is Mr. Silverbridge available?
  4. Were Mycroft speaking in a coded language, what would you make of it?Hepplethwaite, is Virgil a careless or mischievous boy?

comment:6 by dreammaster, 4 years ago

I fixed the problem with the conversation screwup after viewing the journal. As for the original bug about potential deadend, it may quite possibly be a result of another screwup that 8ee889b fixed - something not as obviously wrong as "double characters", but still not setting a global flag that should have been. I'm going to mark this as fixed, and we can re-open it if the problem is ever repeated in a fresh game.

comment:7 by dreammaster, 4 years ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.