Opened 4 years ago

Closed 4 years ago

#6902 closed defect (fixed)

SHERLOCK - double snuff box

Reported by: SF/mimdoe Owned by: dreammaster
Priority: normal Component: Engine: Sherlock
Keywords: Cc:
Game: Sherlock Holmes: Case of the Rose Tattoo

Description

I picked up the snuff box in the Diogenes Club and then found it again. Savageme attached: snuff box is in the inventory and also on the floor.

Ticket imported from: bugs/6902.

Attachments (1)

rosetattoo.024 (17.8 KB ) - added by SF/mimdoe 4 years ago.

Download all attachments as: .zip

Change History (6)

by SF/mimdoe, 4 years ago

Attachment: rosetattoo.024 added

comment:1 by dreammaster, 4 years ago

I've tried and failed to replicate the problem. The game uses a special array scalled _sceneStats to track, for each scene, whether each object should be hidden. For the entry hall of the Diogenes club, _sceneStats[7][44] represents the Snuff box, and in the attached savegame it's false. But after getting the box originally, it should have been set by either leaving the scene or starting to save your game. Since the savegame is from the Diogenes club interior, the only thing I can think of is that something else you did caused a memory corruption and reset the flag on the object.

If you have a slighter earlier savegame, could you see whether you can replicate the problem again?

comment:2 by SF/mimdoe, 4 years ago

I have earlier savegame but can't replicate it. Coincidentally the game froze completely when I tried to replicate snuff box error and looked at the clock and than talked to Watson in Diogenes club. But even this I can't replicate.

comment:3 by dreammaster, 4 years ago

I'd be interested in if you remember the sequence of events that occurred between first picking up the snuffbox and then "finding it again". In particular, did you:
Leave and return to the room
Save and/or load using the original save dialog? Or the GMM, and if so, via the Right click Verb menu, GMM, or hotkey?
* Anything else you may have done.

I aksed in one of the other bug reports, but just in case you don't see it there, it would also help to have the details of your system, and which ScummVM build you used.

comment:4 by dreammaster, 4 years ago

Actually, nevermind. After a careful investigation of the code, and some trial and error, I figured out that a secondary flag for whether a savegame had been loaded wasn't being cleared if you loaded a savegame directly from the launcher. Because of this, you could do things in a scene, but then doing a further save, or leaving the scene, would result in the global flags not being updated.

Which is likely the cause of all the various oddities you noticed, such as the double snuffbox, or characters being duplicated. I'm going to go ahead and close the bulk of them that sound similar. Specific ones can always be re-opened if still found to be a problem.

comment:5 by dreammaster, 4 years ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.