Opened 16 years ago

Closed 16 years ago

Last modified 8 months ago

#688 closed defect (worksforme)

ALL: Mouse Cursor disappears when not Moving

Reported by: SF/tetrapak Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

ScummVM 0.3.1cvs, Win2k, Win32

If you stop moving the mouse around, the cursor
disappears from screen.

Happened in:

Zak FM towns ENG

Sam&Max ENG

DOTT GER Talkie

The standard action in DOTT is not highlighted when the
cursor is invisible, but one is able to execute it when
right-clicking.

probably affects all games.

Ticket imported from: #679180. Ticket imported from: bugs/688.

Change History (7)

comment:1 Changed 16 years ago by fingolfin

This is not a bug in the GUI, as you are talking about the in-game cursor. Does the problem occur in 0.3.0b ?

comment:2 Changed 16 years ago by fingolfin

Summary: Mouse Cursor disappears when not MovingALL: Mouse Cursor disappears when not Moving

comment:3 Changed 16 years ago by SF/tetrapak

Nope, this bug is not in 0.3.0b.

I checked the latest Build 0.3.2cvs and the bug is still there.

The Cursor is ok when being in Main-Menu or Debug-Mode
(0.3.2cvs), so yes, it seems to be an in-game Problem.

Additionally to the disappearing Cursor, the highlighting of the
default action (e.g. look at) in MI2 or DOTT is blinking and
even if the mouse cursor is over a e.g. Banana after short time
there's another Item selected, e.g. the Organ.

comment:4 Changed 16 years ago by fingolfin

I can't reproduce this with current CVS in any game I tested with (Dig, COMI, Monkey2, DOTT).

comment:5 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed

comment:6 Changed 16 years ago by fingolfin

Nobody else (including windows users) seems to be able to reproduce it.

comment:7 Changed 8 months ago by digitall

Component: --Unset--Engine: SCUMM
Note: See TracTickets for help on using tickets.