Opened 17 years ago

Closed 17 years ago

#683 closed defect (worksforme)

DOTT: Music does not stop

Reported by: SF/leekfossil Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

Hello there!

When I change between the characters, the music of
the character before does not stop. The Music starts,
but the other two songs are still playing in the
background, so that I hear three songs at one time.

I use the following versions:

ScummVM 0.3.0b
German CD version
Windows XP Professional

Ticket imported from: #678667. Ticket imported from: bugs/683.

Change History (7)

comment:1 by Kirben, 17 years ago

Summary: Music does not stopDOTT: Music does not stop

comment:2 by eriktorbjorn, 17 years ago

I can't reproduce this with the English CD version of DOTT.
Does that mean the English and German version handle the
music differently?

comment:3 by SF/leekfossil, 17 years ago

Perhaps. The problem only occurs sometimes. When there is
a key-scene between, the music plays normaly again.

But I have another problem:

Evertime I play Hoagie and try to put the stamp on the letter,
the game crashes. I did not try it with another character so
far, perhaps it's Hoagie's fault! :o)

comment:4 by SF/yokitori, 17 years ago

I was experimenting the same bug after giving Dr Fred the
true coffe for he to sign the contract... The music that starts
when he recovers did not stop, even if I changed character... I
got rid of that music after setting the music volume to 0 for a
long while, but I m not sure this is the fact to have set the
volume or the while (I believe it is more the while....) that set
me free of that horrible sound....

comment:5 by fingolfin, 17 years ago

leekfossil, if you still have that stamp crash, please file a seperate bug report on it.

comment:6 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed

comment:7 by fingolfin, 17 years ago

Yokitori, what you describe sounds like bug https://sourceforge.net/tracker/index.php?func=detail&aid=666187&group_id=37116&atid=418820

In any case, I can't reproduce this problem with latest CVS, I think Jamieson fixed it some time ago (before he left us for boring things like his "job" and his "real life". I mean, come on, who on earth needs an "income" ??? :-)

Note: See TracTickets for help on using tickets.