Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6816 closed defect (fixed)

SCI: SQ1VGA: game crash when looking at force field generator

Reported by: SF/glorifindel Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: original script Cc:
Game: Space Quest 1

Description

ScummVM 1.70 - Win7 64 - Space Quest 1 VGA - from the collector's edition cd

Game crashes when looking at one of the two rotating force field generators.
The console reports: [VM] op_bnt: request to jump past the end of script 45 (offset -4096, script is 11566 bytes)!

Savegame attached.

Ticket imported from: bugs/6816.

Attachments (1)

sq1sci.010 (38.1 KB ) - added by SF/glorifindel 5 years ago.

Download all attachments as: .zip

Change History (7)

by SF/glorifindel, 5 years ago

Attachment: sq1sci.010 added

comment:1 by m-kiewitz, 5 years ago

I am unable to reproduce the bug.

I tried looking at both force field generators and it works for me. It works with the latest build and the official 1.7 build works too.

Can you please tell me, if there is a file called 45.scr in your Space Quest 1 directory and if so how large that file is.

And which Collector's Edition do you own?
Is it one of the collections mentioned on this page? http://wiki.scummvm.org/index.php/SCI/Game_Collections

comment:2 by SF/glorifindel, 5 years ago

The collection is Roger Wilco Unclogged, there's no file called 45.scr.
If it can help, please try to look at the generators more than once, I've just tried, and sometimes the game crashes at the 3rd attempt.

comment:3 by m-kiewitz, 5 years ago

Thanks. I was able to reproduce it. And we figured out, that the bug always occurs when you click on the upper part of the force field generator.

The script code, that triggers this error, is really weird and I just found out that the original Sierra interpreter bombs out with the common "Oops, you did something that we didn't expect" as well.

Will write a script patch for this issue.

comment:4 by m-kiewitz, 5 years ago

script patch added in 84631468561c3df20cfd073d20c35344be4c6f3f
the script bug is now getting patched out on-the-fly

comment:5 by m-kiewitz, 5 years ago

Keywords: original script added
Owner: set to m-kiewitz
Resolution: fixed
Status: newclosed

comment:6 by SF/glorifindel, 5 years ago

Thanks!

Note: See TracTickets for help on using tickets.