Opened 4 years ago

Last modified 7 months ago

#6811 new defect

ANDROID: kyra.dat error on loading EOB

Reported by: SF/meunierd Owned by:
Priority: normal Component: Port: Android
Keywords: Cc:
Game: Eye of the Beholder 1

Description

Running the latest Android nightly build. I get an error regarding kyra.dat when trying to load EOB; saying it's either missing or corrupt. Is this possible side-loading an APK? Was I supposed to place it somewhere myself?

The same data works fine on my 1.7.0 Linux build.

Ticket imported from: bugs/6811.

Change History (10)

comment:1 Changed 4 years ago by digitall

ScummVM searches the Extra Path defined, the game data directory and the current directory for these engine data files.

Do you have a kyra.dat in your game data directory? If so, you need to ensure it is the latest from here: https://github.com/scummvm/scummvm/tree/master/dists/engine-data

comment:2 Changed 4 years ago by digitall

I have checked the latest APK from the buildbot. Since APKs are just zip files, you can decompress them and see for yourself.

kyra.dat is included as assets/kyra.dat ...

comment:3 Changed 4 years ago by lordhoto

Android implements "addSysArchivesToSearchSet". So, it should pick up the bundled version if it's installed correctly. Probably something is broken there.

Adding kyra.dat to your game directory is a workaround. It shouldn't be needed for most platforms ScummVM runs on.

comment:4 Changed 4 years ago by SF/meunierd

Adding kyra.dat manually from github fixed the issue, thanks!

comment:5 Changed 3 years ago by sev-

Owner: set to sev-
Resolution: invalid
Status: newclosed

comment:6 Changed 3 years ago by SF/pegasusepsilon

This should never have been closed-invalid. This is a legitimate bug that still persists up through version 1.9.0. Putting kyra.dat (a ScummVM file) into the game data directory (where files from the game go) is a workaround, not a fix.

comment:7 Changed 3 years ago by bgK

Owner: sev- deleted
Resolution: invalid
Status: closednew

comment:8 Changed 3 years ago by bgK

Reproduced with Kyra 2 demo, using curent master (2e675468)
This may be because AndroidAssetArchive is case sensitive.

comment:9 Changed 13 months ago by bonki

Component: Engine: KyraPorts

comment:10 Changed 7 months ago by digitall

Component: PortsPort: Android
Summary: kyra.dat error on loading EOBANDROID: kyra.dat error on loading EOB
Note: See TracTickets for help on using tickets.