Opened 5 years ago

Closed 5 years ago

#6807 closed defect (fixed)

SCI: QFG3: Export Character Magic spell open skill being bump up.

Reported by: SF/powersliderr1 Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: original script Cc:
Game: Quest for Glory 3

Description

Quest For GLory 3 character save (export character) when imported in to 4 (dosbox & GOG) Magic skill for open is 24970 though in Quest for glory 3 it was 300, and default wizard start with this spell skill at 200. Also Latest build when attempting to import a character into it the character name gets filled with x's just FYI.

Ticket imported from: bugs/6807.

Attachments (4)

OpenSkill on import.png (261.5 KB ) - added by SF/powersliderr1 5 years ago.
qfg3-Kpal.sav (286 bytes ) - added by SF/powersliderr1 5 years ago.
qfg3.010 (94.3 KB ) - added by SF/powersliderr1 5 years ago.
alternate (158 bytes ) - added by SF/powersliderr1 5 years ago.

Download all attachments as: .zip

Change History (14)

by SF/powersliderr1, 5 years ago

Attachment: OpenSkill on import.png added

by SF/powersliderr1, 5 years ago

Attachment: qfg3-Kpal.sav added

comment:1 by SF/powersliderr1, 5 years ago

Character Save file.

by SF/powersliderr1, 5 years ago

Attachment: qfg3.010 added

comment:2 by SF/powersliderr1, 5 years ago

Game save pre export.

Other Magic skills are boosted to 300 and added at the end of the game but I am no sure if this is intentional or a bug such as magic detect is at 200 and in 4 it becomes 300 also Zap does he same as it was at 112 and becomes 300 Post import to 4. If you want a save that you can see the magic skills in just let me know.

comment:3 by SF/powersliderr1, 5 years ago

Upon further inspection it does not seem to matter GOG or NON GOG version as loading the save and using the non GOG version of the game same issue happens Though the value written to that attribute is different but still Overly high.

comment:4 by wjp, 5 years ago

Summary: Export Character Magic spell open skill being bump up.SCI: QFG3: Export Character Magic spell open skill being bump up.

comment:5 by SF/powersliderr1, 5 years ago

Found an Save editor tool to examine what was being written to after the export of quest for glory 3 and checked my other saves and they where valid but 3 has over flows all over the place. (http://blazingstix.com/apps/qfgimporter) and upon review with this application incorrect values are written in the fallowing value fields: Experiance, as for spells all are incorrect but Open, Calm, Flamedart, Fetch, Force bolt, Levitation, Reversal are above max value.

comment:6 by m-kiewitz, 5 years ago

I researched this a bit. It seems you have 53481 experience points internally. They aren't shown, but they are there. And this causes all the issues. At least that's what it looks like. When i change that to 10000 experience points, the whole character file looks fine. And the experience issue is a known bug in the character export.

Did you transfer your character from Quest For Glory 1 to QfG2, then to QfG3? Can you please check how many experience points you had at the end of QfG2? And how long did you play QfG3?

by SF/powersliderr1, 5 years ago

Attachment: alternate added

comment:7 by SF/powersliderr1, 5 years ago

The character was indeed a carried through all 3 games. I will look at how
many exp I had in 2 as for 3 Are you asking for time in game?

comment:8 by m-kiewitz, 5 years ago

Keywords: original script added
Owner: set to m-kiewitz
Resolution: fixed
Status: newpending

comment:9 by m-kiewitz, 5 years ago

I added a script patch for this script bug. It also occurs in the original, although I'm not sure if your insanely high experience points weren't caused by some other bug. Your experience points are 53481, which is REALLY high.

The script patch will change all values to 9999 in case they are 10000 or higher, when exporting the character.

Please check how much experience points you had at the end of Quest For Glory 2.

Script patch was added in 537f33d9cf60fffdd473ae3cd32e2abffc9cb24f. The next daily build should include it. Please download and try it out. I will keep this bug report open.

The script patch applies to the official English, French, German, Italian and Spanish version of the game. I haven't tried with the version from GOG.

btw. it seems Quest for Glory 4 also has such a bug.

comment:10 by m-kiewitz, 5 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.