Opened 2 years ago

Closed 9 months ago

#6806 closed defect (fixed)

SCI: QFG3: Dialog Crash about Leopard women's marriage.

Reported by: SF/powersliderr1 Owned by: wjp
Priority: low Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 3

Description

Unable to continue on dialog path as it causes ScummVM to completely crash. On current build 1.7.0 Upon loading the save talk to Uhura And select the dialog option "Woo" and it will immediately crash. with a signature mismatch error.

Ticket imported from: bugs/6806.

Attachments (1)

qfg3.008 (85.2 KB) - added by SF/powersliderr1 2 years ago.

Download all attachments as: .zip

Change History (9)

Changed 2 years ago by SF/powersliderr1

Attachment: qfg3.008 added

comment:1 Changed 2 years ago by wjp

I can reproduce that from the savegame:

parameter 0: 0000:0005 (integer), should be null, integer
parameter 1: 033d:01a0 (reference, invalid), may be any (optional) (more may follow)
[VM] kMemory[72]: signature mismatch via method ::export 6 (room 440, script 999, localCall 0xffffffff)!

comment:2 Changed 2 years ago by wjp

Summary: Dialog Crash about Leopard women's marriage.SCI: QFG3: Dialog Crash about Leopard women's marriage.

comment:3 Changed 2 years ago by wjp

Also see
https://sourceforge.net/p/scummvm/bugs/5172/

I haven't investigated why that patch isn't working here yet.

comment:4 Changed 2 years ago by wjp

This should be fixed now; thanks for the report.

This was a script bug in the original game, which we have fixed in the past, but it turns out that the GOG version of QfG3 (which I assume you're using), has a slightly different version of the faulty script.

If you're not using the GOG version, could you let us know which version you do have?

comment:5 Changed 2 years ago by SF/powersliderr1

I was using the GOG version. Just a heads up QFG3 is nearly unplayable in 1.8 builds currently on certain Rooms just checking the stat screen causes the game to crash. I can think of on in particular In simbani Village going to the bridge and then opening the stats screen then clicking to leave will indeed cause a crash. I have a list of more but this is not the time nor place to discuss. and i am a little to busy to look into the scumm code to see what is exactly causing the errors against my console output.

comment:6 Changed 2 years ago by wjp

I also get that crash in the Simbani bridge room, from a piece of code that checks for script bugs. This code is disabled in our release builds, which is why you're not getting this crash in 1.7. If you can submit a new bug report with this list, we can try to fix or work around these script bugs in QfG3.

comment:7 Changed 2 years ago by wjp

mkiewitz and I have investigated this a bit more: it turns out that GOG has released QfG3 with a set of unofficial patches (by NRS), and these patches introduce a number of issues.

Most of our own testing was with the official Sierra release of Quest for Glory 3 with only official patches, so we hadn't looked at these before.

We would really appreciate your list of crash locations to be able to properly address them.

comment:8 Changed 9 months ago by wjp

Owner: set to wjp
Resolution: fixed
Status: newclosed

Moved the Simbani bridge crash to new ticket #9605. Closing this one.

Note: See TracTickets for help on using tickets.