Opened 6 years ago

Closed 2 weeks ago

#6800 closed defect (fixed)

ZVISION Cannot be compiled on Android - FreeType2 isn't available

Reported by: SF/youngbilly Owned by: ccawley2011
Priority: normal Component: Port: Android
Keywords: Cc:
Game: Zork Nemesis

Description

ScummVM version 1.8,0git2728-g531029f GOG version installed under Win8, and game folder xfer by USB to sdcard on phone running Android 4.4.4 (CM3.4) English Language Browse into game folder to add game gives 'ScummVM could not find any game in the specified directory!' message.

Ticket imported from: bugs/6800.

Change History (10)

comment:1 by sev-, 6 years ago

A question. Do this same game data get recognised on your desktop?

comment:2 by SF/youngbilly, 6 years ago

Hi - yes, it works fine. The GOG version starts DOSBOX. I've tried clean installs of the game and recopying the GOG unpacked game folder a few times, plus the last couple of days of ScummVM builds. Same result.

comment:3 by SF/youngbilly, 6 years ago

Apologies if I misunderstood - the game works with daily build for Windows on my PC but not with the ARM build on my mobile. Same game folder.

comment:4 by SF/youngbilly, 5 years ago

OK - LordHoto on the forum says 'the Android daily build does not include ZVision. It is missing the FreeType2 dependency which is (set as) required for ZVision.'

comment:5 by bluegr, 5 years ago

Owner: set to fuzzie
Summary: Zork Nemesis on android - no game foundZVISION Cannot be compiled on Android - FreeType2 isn't available

comment:6 by bluegr, 5 years ago

So, the actual issue is that FreeType2 isn't available on the Android port. Assigning this to fuzzie

comment:7 by csnover, 3 years ago

Owner: changed from fuzzie to csnover

This is not a ScummVM defect but a limitation of the old build system which will be addressed with the new Buildbot, which includes a FreeType library for Android.

comment:8 by digitall, 22 months ago

Owner: csnover removed

comment:9 by ccawley2011, 12 months ago

Component: Engine: ZVisionPort: Android

FreeType is now installed on the Buildbot for both ARMv5 and AArch64, as mentioned in https://github.com/scummvm/scummvm/pull/1278. It's still missing on x86 and Ouya, though.

comment:10 by ccawley2011, 2 weeks ago

Owner: set to ccawley2011
Resolution: fixed
Status: newclosed

All Android toolchains on the buildbot now have FreeType, as well as any other libraries they were previously missing. As such, this issue can now be closed.

Note: See TracTickets for help on using tickets.