Opened 16 years ago

Closed 16 years ago

#680 closed defect (worksforme)

MI1VGA: reproducable vm crash in governer's house

Reported by: SF/hannomueller Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

scummvm -v: 0.3.0b

Game: German CD version, scummvm identifies it as
"Monkey Island 1 (256 color Floppy version)", Savegame
dialog says "Monkey Island (VGA) V1.1"

Platform: Occured in Zaurus ARM Binary
(http://gnurou.org/software/zaurus/). Then I tried
again with the Debian "unstable" x86 Binary of the same
version, same error. So it could be a VM issue.

Detail: Load attached savegame. When walking past the
bookshelf, scummvm crashes.

Output:

Looking for monkeyvga
Detected game 'Monkey Island 1 (256 color Floppy
version)', version 5.0.16
Loading room 90
Loading room 0
Loading room 10
Loading room 0
Loading room 38
Adding object 497 from room 38 into inventory
Loading room 96
Loading room 33
State loaded from 'monkeyvga.s06'
Error(53:202:0x3F45): Value 16846 is out of bounds
(0,4095) int script(25) msg Bit variable %d out of
range(r)!

Ticket imported from: #675873. Ticket imported from: bugs/680.

Attachments (1)

monkeyvga.s06 (33.0 KB) - added by SF/hannomueller 16 years ago.
Savegame

Download all attachments as: .zip

Change History (9)

Changed 16 years ago by SF/hannomueller

Attachment: monkeyvga.s06 added

Savegame

comment:1 Changed 16 years ago by Kirben

Summary: reproducable vm crash in governer's houseMIVGA: reproducable vm crash in governer's house

comment:2 Changed 16 years ago by Kirben

Summary: MIVGA: reproducable vm crash in governer's houseMI1VGA: reproducable vm crash in governer's house

comment:3 Changed 16 years ago by SF/ender

Does anybody actually have a german version of this game to
test with?

I cannot replicate bug from a clean run of the English version.

comment:4 Changed 16 years ago by SF/hannomueller

Obviously, I do. (Bought the original.) I don't quite know
how I can legally let you have it for testing, though.

comment:5 Changed 16 years ago by fingolfin

I have the german MIVGA and it crashes here, too. However, the save game has a really weird save name, so I wonder if it's simply corrupt? I'll debug it.

comment:6 Changed 16 years ago by SF/hannomueller

I saved it from within the Zaurus version of scummvm
(http://gnurou.org/software/zaurus/), but since all its
savegames worked also in the Debian x86-Binary for the same
version, I thought things were okay.

The error message is also more or less the same on both
platforms.

Anyway, if you wish I can provide more savegame files that I
made on the Zaurus for MI1.

Thanks to you guys for looking into this! Scummvm is a great
waste-of-time-tool. :-)

comment:7 Changed 16 years ago by fingolfin

I just played through till this point from the start. No crash occured. So I really think your save game is the problem... could you try to play there from the start, too, and see if you still have the problem or not? It's a matter of ten minutes or less.

This is with head CVS.

comment:8 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.