Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6799 closed defect (fixed)

HUGO: Silent quit when using inventory

Reported by: misterhands Owned by: eriktorbjorn
Priority: normal Component: Engine: Hugo
Keywords: Cc:
Game: Hugo

Description

ScummVM 1.8.0git2727-g666a4f3 (Feb 3 2015 21:52:09) Win32
Features compiled in: TAINTED Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC FreeType2 JPEG PNG

HUGO 1/2/3 Windows

ScummVM sometimes quits silently when manipulating inventory objects. No error or warning.
One way to reproduce is to load the attached savegame, select an item by right-clicking it and move it around. Moving it so that the object's description text hits the top of the screen triggers the bug nearly every time (with the item text at times showing corrupted), but sometimes simply using an item on a hotspot will be enough.

Ticket imported from: bugs/6799.

Attachments (1)

hugo2-win-16.SAV (6.9 KB ) - added by misterhands 5 years ago.

Download all attachments as: .zip

Change History (6)

by misterhands, 5 years ago

Attachment: hugo2-win-16.SAV added

comment:1 by eriktorbjorn, 5 years ago

I just committed a change that should at least partly fix this. It guards against drawing the cursor text above the top of the screen, which is the crash I was able to reproduce. I'm not sure this covers the last thing you mentioned, so I'm leaving the bug report open for now.

comment:2 by eriktorbjorn, 5 years ago

Owner: set to eriktorbjorn

comment:3 by eriktorbjorn, 5 years ago

Resolution: fixed
Status: newclosed

comment:4 by eriktorbjorn, 5 years ago

Since I haven't heard anything about any remaining bugs (in regards to this one), I'm going to close it.

comment:5 by misterhands, 5 years ago

That's fine, I can't seem to make it crash anymore so it's probably fixed.
Thanks Torbjörn!

Note: See TracTickets for help on using tickets.