Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6793 closed defect (fixed)

ZVISION: Saving at bottom of staircase creates buggy savegame

Reported by: eriktorbjorn Owned by: bluegr
Priority: normal Component: Engine: ZVision
Keywords: original Cc:
Game: Zork Nemesis

Description

Current Git snapshot of ScummVM. English Zork Nemesis, included on DVD version of ZGI.

I've provided two savegames: One just before the bug happens, and one after.

If I load the first savegame, walk down the stairs and immediately save the game there, I'm moved back to the stairs but without any hotspots. So I'm stuck in that room, with no apparent way to get out.

I have not yet tried to figure out what causes this, and at the moment I don't even know where to start looking.

Ticket imported from: bugs/6793.

Attachments (2)

znemesis.006 (12.8 KB ) - added by eriktorbjorn 5 years ago.
znemesis.007 (11.7 KB ) - added by eriktorbjorn 5 years ago.

Download all attachments as: .zip

Change History (5)

by eriktorbjorn, 5 years ago

Attachment: znemesis.007 added

comment:1 by eriktorbjorn, 5 years ago

I tried reproducing this in DOSBox, but it seems I can't even save at this particular point in the game there.

comment:2 by bluegr, 5 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:3 by bluegr, 5 years ago

A script bug, fixed in commit f04ef8b728.

Thanks for your bug report, closing as fixed

comment:4 by bluegr, 5 years ago

Keywords: original added
Note: See TracTickets for help on using tickets.