Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6780 closed defect (fixed)

ZVISION: Non-working, game-breaking hotspot at bottom of tower

Reported by: eriktorbjorn Owned by: bluegr
Priority: normal Component: Engine: ZVision
Keywords: script Cc:
Game: Zork Grand Inquisitor

Description

Current Git snapshot of ScummVM, English DVD version of the game.

I'm at the bottom of the tower, near the end of the game (see attached savegame), and there's a mysterious hotspot to the right that, if I click on it, produces the following warning:

WARNING: Script file not found: em1n.scr!

After that, it's pretty much impossible to proceed. All of the hotspots are gone. I can bring up the inventory, but then I can't go back to the game again.

Is this a ScummVM bug, or did I mess up my ZGI installation somehow?

Ticket imported from: bugs/6780.

Attachments (1)

zgi-win.032 (24.1 KB ) - added by eriktorbjorn 5 years ago.

Download all attachments as: .zip

Change History (3)

by eriktorbjorn, 5 years ago

Attachment: zgi-win.032 added

comment:1 by bluegr, 5 years ago

Keywords: script added
Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:2 by bluegr, 5 years ago

This is a game script bug - it's a hotspot that doesn't lead anywhere. In the original, it just doesn't do anything. In ScummVM, it takes you to an invalid scene, and then nothing works.

I've disabled the invalid hotspot in commit 1bd83a9. I don't believe it's worth the effort to try and handle script bugs like this in any graceful manner, so the engine will error out in such cases (commit d75fbe7).

Closing as fixed

Note: See TracTickets for help on using tickets.