Opened 17 years ago

Closed 17 years ago

Last modified 15 months ago

#678 closed defect (fixed)

INDY3: Can't fight

Reported by: SF/boondoncksaint Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

ScummVM0.3.0b

Indiana Jones and the Last Crusade (256)

winXP pro

If I play the none-ScummVM version... I can fight using the numpad keys (you can test it very easy by fighting the guy in the very beginning of the game...just go back to the locker). In the ScummVM game I cant throw a punch, I can't move...nothing...

*SPOILER: WHY THIS IS IMPORTANT*

In the nazi castle: I gave the throphy filled with beer to the big guard.... he wants to fight me....but he has only one tiny stripe of energy left....so I need to punch him ONCE to floor him...but I can't !!!....I dont think there is another way past him....hence I can't finish the game

*/SPOILER

Ticket imported from: #672900. Ticket imported from: bugs/678.

Change History (5)

comment:1 by SF/khalek, 17 years ago

I think this may be due to the keyboard navigation stuff.. as it used to work quite some time ago. You can use some of the number keys above the letters on your keyboard for now.. but this really needs to be addressed properly at some point

comment:2 by SF/boondoncksaint, 17 years ago

thx alot...stupid me....Since I have an azerty keyboard the numerics are all CAPS....so you have to press SHIFT + number if you are not using numpad....

But still....little bug....numpad doesn't work....but I can at least finish my game now....thx

comment:3 by fingolfin, 17 years ago

Hm, numpad fighting works just fine for me in Indy 3, with latest CVS (not that I would recommend using latest CVS for anything besides CoMI right now, because we introduced quite some regressions).

comment:4 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:5 by digitall, 15 months ago

Component: Engine: SCUMM
Game: Indiana Jones 3
Note: See TracTickets for help on using tickets.