Opened 17 years ago

Closed 17 years ago

#676 closed defect (fixed)

ZAK256 crashes when turning on lighter in seatle cave

Reported by: SF/derschrauber Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

ScummVM-Version: 0.3.1-cvs (2002-12-28), latest CVS-
build downloaded from ScummVM.sf.net 2003-01-19

ScummVM crashes when I turn on the lighter in the
Seatle cave. (The one with the two-headed squirrel)

When I turn on the lighter, for a second I can see the
spot of the light, then ScummVM crashes.

I can turn on the lighter outside of the cave, but as soon
as I enter the cave it crashes, too.

I included the output of ScummVM

----------- output of the programm
C:\ScummVM>scummvm
Looking for zak256
Trying to start game 'Zak McKracken and the Alien
Mindbenders (256)', version 3.
0.0
Allocated 200 space in numObjects
Assertion failed: 1 <= bit && bit <= 96, file
scumm/usage_bits.cpp, line 42

This application has requested the Runtime to terminate
it in an unusual way.
Please contact the application's support team for more
information.

Ticket imported from: #670942. Ticket imported from: bugs/676.

Change History (5)

comment:1 by SF/khalek, 17 years ago

This is a regression due to some mi3 changes by the look of it.
Use 0.3.0b to play zak256 for now

comment:2 by fingolfin, 17 years ago

Owner: set to fingolfin
Status: newclosed

comment:3 by SF/khalek, 17 years ago

reopening.. as we have to address these regression issues

comment:4 by SF/khalek, 17 years ago

Status: closednew

comment:5 by fingolfin, 17 years ago

Owner: changed from fingolfin to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.