Opened 5 years ago

Closed 12 months ago

#6758 closed defect (wontfix)

Eye of the Beholder 1: no "silver key" in the beginning of the Level 2

Reported by: SF/toney-moon Owned by: athrxx
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Eye of the Beholder 1

Description

ScummVM 1.7.0 (Jul 16 2014 16:33:22)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora AAC FreeType2 PNG

Game: Eye of the Beholder 1
Problem: There is no "silver key" in the beginning of the Level 2, but it has to be there according to the official Clue Book:
"Locations and Events:
1 . There is a ladder on the west wall
leading up to level 1, location 19, as well".
How to reproduce: create a random party, start a game & finish Level 1, then go to Level 2 & find yourself before 3 closed doors.
See the picture.

Ticket imported from: bugs/6758.

Attachments (2)

EOB2.png (91.8 KB ) - added by SF/toney-moon 5 years ago.
EOB3.png (84.8 KB ) - added by SF/toney-moon 5 years ago.

Download all attachments as: .zip

Change History (7)

by SF/toney-moon, 5 years ago

Attachment: EOB2.png added

comment:1 by athrxx, 5 years ago

Component: Engine: ZVisionEngine: Kyra
Game: Zork Grand InquisitorEye of the Beholder 1
Owner: set to athrxx

by SF/toney-moon, 5 years ago

Attachment: EOB3.png added

comment:2 by SF/toney-moon, 5 years ago

"1 . There is a ladder on the west wall
leading up to level 1, location 19, as well
as a silver key lying on the ground."

comment:3 by athrxx, 5 years ago

Unfortunately we can't reproduce these bugs, neither with Windows nor Linux. There aren't any mouse pointers showing up in the inventory and the key in Level 2 is right where it is supposed to be.

Maybe this is a problem with the game data. What game version do you have? Where did you get it?

comment:4 by bluegr, 5 years ago

I have no such issue with my game version. I get a silver key on the ground when starting that level.

The OP has mentioned on IRC that he has obtained this game via an illegal download:
http://logs.scummvm.org/log.php?log=scummvm.log.10Jan2015&format=html

This looks to be an issue with that specific pirated version. We do not support pirated versions, so I suggest we close this bug report as "Won't fix".

Since this is one of the spots where the game copy protection kicks in, perhaps this version is somehow cracked, and this messes up the location of the silver key?

comment:5 by digitall, 12 months ago

Resolution: wontfix
Status: newclosed

Since this bug is likely due to corrupted datafiles or game protection, and is not replicable in any case, closing this as WONTFIX.

Note: See TracTickets for help on using tickets.