Opened 10 years ago

Closed 8 years ago

Last modified 6 years ago

#6755 closed defect (fixed)

ScummVM Crashes in OS X after multiple full screen changes

Reported by: SF/vonmagnum Owned by: criezy
Priority: normal Component: Port: Mac OS X
Version: Keywords:
Cc: Game:

Description

I get a problem with ScummVM (occurred in V1.5 and is still there after updating to V1.7) crashing with a beach ball of death on the Mac OS X version (running Mavericks Final here) when I change from window mode to full screen (alt enter) after 2 times. In other words, if I start in a window, I can switch to full screen. I can then switch back to a window and into full screen one more time, but when I switch to Window Mode and then to Full Screen Mode the next time, it freezes and/or beach balls and then sometimes finally crashes/closes (other times it just sits there locked up). This is VERY repeatable here (every time so far) and appears to happen with ALL games tried so far (verified on Curse of Monkey Island, Amiga Maniac Mansion, PC V2 Maniac Mansion, Amiga Zak McKracken). I don't recall this occuring in the past, so it might be specific to Mavericks or might have been introduced in an upgrade (I don't often switch back and forth like that so I never noticed it, but I was looking up various unseen endings, etc. and needed to get back to OS X to use the web browser. I got this error reported by OS X when I did get a full close on Curse of Monkey Island:

Process: scummvm [35432] Path: /Users/USER/*/ScummVM.app/Contents/MacOS/scummvm Identifier: org.scummvm.scummvm Version: 1.7.0 (1.7.0) Code Type: X86 (Native) Parent Process: launchd [202] Responsible: scummvm [35432] User ID: 501

Date/Time: 2015-01-06 17:55:41.731 -0500 OS Version: Mac OS X 10.9.5 (13F34) Report Version: 11 Anonymous UUID: A2CD42EB-FE35-0470-2CB9-CC36DE965B76

(Crashed Thread: 1 Dispatch queue: com.apple.libdispatch-manager Exception Type: EXC_CRASH (SIGBUS) Exception Codes: 0x0000000000000000, 0x0000000000000000

Thread 0:: Dispatch queue: com.apple.main-thread 0 libobjc.A.dylib 0x931644ab objc_msgSend + 27 1 com.apple.CoreFoundation 0x9524649c CFArrayGetCount + 108 2 org.scummvm.scummvm 0x01058c87 0x1000 + 17136775 3 org.scummvm.scummvm 0x00ff46bb 0x1000 + 16725691 4 org.scummvm.scummvm 0x00ff504c 0x1000 + 16728140 5 org.scummvm.scummvm 0x00ff6515 0x1000 + 16733461 6 org.scummvm.scummvm 0x00ea0673 0x1000 + 15332979 7 org.scummvm.scummvm 0x00e9bccf 0x1000 + 15314127 8 org.scummvm.scummvm 0x00e9c00b 0x1000 + 15314955 9 org.scummvm.scummvm 0x00e9d8f0 0x1000 + 15321328 10 org.scummvm.scummvm 0x00e9dedd 0x1000 + 15322845 11 org.scummvm.scummvm 0x00fbb9b6 0x1000 + 16492982 12 org.scummvm.scummvm 0x00fbbb84 0x1000 + 16493444 13 org.scummvm.scummvm 0x00e93d99 0x1000 + 15281561 14 org.scummvm.scummvm 0x000ef77a 0x1000 + 976762 15 org.scummvm.scummvm 0x000277d3 0x1000 + 157651 16 org.scummvm.scummvm 0x00028c41 0x1000 + 162881 17 org.scummvm.scummvm 0x01354862 Scumm::ScummEngine::run() + 162 18 org.scummvm.scummvm 0x00009101 0x1000 + 33025 19 org.scummvm.scummvm 0x00006687 0x1000 + 22151 20 org.scummvm.scummvm 0x00ff0e5b 0x1000 + 16711259 21 com.apple.Foundation 0x910e59f2 57-[NSNotificationCenter addObserver:selector:name:object:]_block_invoke + 49 22 com.apple.CoreFoundation 0x9535c5a4 __CFNOTIFICATIONCENTER_IS_CALLING_OUT_TO_AN_OBSERVER + 20 23 com.apple.CoreFoundation 0x9523e04b _CFXNotificationPost + 3435 24 com.apple.Foundation 0x910d44df -[NSNotificationCenter postNotificationName:object:userInfo:] + 92 25 com.apple.AppKit 0x904bd575 -[NSApplication _postDidFinishNotification] + 367 26 com.apple.AppKit 0x904bd215 -[NSApplication _sendFinishLaunchingNotification] + 239 27 com.apple.AppKit 0x904b9b44 -[NSApplication(NSAppleEventHandling) _handleAEOpenEvent:] + 840 28 com.apple.AppKit 0x904b9431 -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 277 29 libobjc.A.dylib 0x9317a304 -[NSObject performSelector:withObject:withObject:] + 77 30 com.apple.Foundation 0x910f473a __76-[NSAppleEventManager setEventHandler:andSelector:forEventClass:andEventID:]_block_invoke + 121 31 com.apple.Foundation 0x910f4271 -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 430 32 com.apple.Foundation 0x910f407b _NSAppleEventManagerGenericHandler + 218 33 com.apple.AE 0x93de2b15 aeDispatchAppleEvent(AEDesc const, AEDesc, unsigned long, unsigned char) + 387 34 com.apple.AE 0x93db1ed6 dispatchEventAndSendReply(AEDesc const, AEDesc*) + 44 35 com.apple.AE 0x93db1dce aeProcessAppleEvent + 318 36 com.apple.HIToolbox 0x973bd571 AEProcessAppleEvent + 55 37 com.apple.AppKit 0x904b5148 _DPSNextEvent + 1089 38 com.apple.AppKit 0x904b4870 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 119 39 com.apple.AppKit 0x904a715c -[NSApplication run] + 727 40 org.scummvm.scummvm 0x00ff15c8 0x1000 + 16713160 41 org.scummvm.scummvm 0x00002f02 0x1000 + 7938 42 org.scummvm.scummvm 0x00002e29 0x1000 + 7721

Thread 1 Crashed:: Dispatch queue: com.apple.libdispatch-manager 0 libsystem_kernel.dylib 0x939f9992 kevent64 + 10 1 libdispatch.dylib 0x98519899 _dispatch_mgr_invoke + 238 2 libdispatch.dylib 0x98519532 _dispatch_mgr_thread + 52

Thread 2: 0 libsystem_kernel.dylib 0x939f9046 __workq_kernreturn + 10 1 libsystem_pthread.dylib 0x9b66bdcf _pthread_wqthread + 372 2 libsystem_pthread.dylib 0x9b66fcce start_wqthread + 30

Thread 3: 0 libsystem_kernel.dylib 0x939f9046 __workq_kernreturn + 10 1 libsystem_pthread.dylib 0x9b66bdcf _pthread_wqthread + 372 2 libsystem_pthread.dylib 0x9b66fcce start_wqthread + 30

Thread 4: 0 libsystem_kernel.dylib 0x939f9046 __workq_kernreturn + 10 1 libsystem_pthread.dylib 0x9b66bdcf _pthread_wqthread + 372 2 libsystem_pthread.dylib 0x9b66fcce start_wqthread + 30

Thread 5: 0 libsystem_kernel.dylib 0x939f9046 __workq_kernreturn + 10 1 libsystem_pthread.dylib 0x9b66bdcf _pthread_wqthread + 372 2 libsystem_pthread.dylib 0x9b66fcce start_wqthread + 30

Thread 6: 0 libsystem_kernel.dylib 0x939f87ca __psynch_cvwait + 10 1 libsystem_pthread.dylib 0x9b66cd8a _pthread_cond_wait + 837 2 libsystem_pthread.dylib 0x9b66efa3 pthread_cond_wait + 48 3 org.scummvm.scummvm 0x00ffd112 0x1000 + 16761106 4 org.scummvm.scummvm 0x00ea0cbf 0x1000 + 15334591 5 org.scummvm.scummvm 0x00ea0cfb 0x1000 + 15334651 6 org.scummvm.scummvm 0x00ffd74d 0x1000 + 16762701 7 org.scummvm.scummvm 0x0105e331 0x1000 + 17158961 8 libsystem_pthread.dylib 0x9b66a5fb _pthread_body + 144 9 libsystem_pthread.dylib 0x9b66a485 _pthread_start + 130 10 libsystem_pthread.dylib 0x9b66fcf2 thread_start + 34

Thread 7: 0 libsystem_kernel.dylib 0x939f9046 __workq_kernreturn + 10 1 libsystem_pthread.dylib 0x9b66bdcf _pthread_wqthread + 372 2 libsystem_pthread.dylib 0x9b66fcce start_wqthread + 30

Thread 8: 0 libsystem_kernel.dylib 0x939f9046 __workq_kernreturn + 10 1 libsystem_pthread.dylib 0x9b66bdcf _pthread_wqthread + 372 2 libsystem_pthread.dylib 0x9b66fcce start_wqthread + 30

Thread 9: 0 libsystem_kernel.dylib 0x939f3f7a mach_msg_trap + 10 1 libsystem_kernel.dylib 0x939f316c mach_msg + 68 2 com.apple.CoreFoundation 0x952a4bf9 __CFRunLoopServiceMachPort + 169 3 com.apple.CoreFoundation 0x952a41d1 __CFRunLoopRun + 1393 4 com.apple.CoreFoundation 0x952a39ea CFRunLoopRunSpecific + 394 5 com.apple.CoreFoundation 0x952a384b CFRunLoopRunInMode + 123 6 com.apple.AppKit 0x9065eb88 _NSEventThread + 283 7 libsystem_pthread.dylib 0x9b66a5fb _pthread_body + 144 8 libsystem_pthread.dylib 0x9b66a485 _pthread_start + 130 9 libsystem_pthread.dylib 0x9b66fcf2 thread_start + 34

Thread 10: 0 libsystem_kernel.dylib 0x939f9046 __workq_kernreturn + 10 1 libsystem_pthread.dylib 0x9b66bdcf _pthread_wqthread + 372 2 libsystem_pthread.dylib 0x9b66fcce start_wqthread + 30

Thread 1 crashed with X86 Thread State (32-bit): eax: 0x00000004 ebx: 0xb00926a0 ecx: 0xb009267c edx: 0x939f9992 edi: 0xb00926a0 esi: 0x985197b9 ebp: 0xb00926f8 esp: 0xb009267c ss: 0x00000023 efl: 0x00000247 eip: 0x939f9992 cs: 0x0000000b ds: 0x00000023 es: 0x00000023 fs: 0x00000023 gs: 0x0000000f cr2: 0x0bc01000

Logical CPU: 0 Error Code: 0x00000171 Trap Number: 132

Binary Images: 0x1000 - 0x15dffa3 +org.scummvm.scummvm (1.7.0 - 1.7.0)

Ticket imported from: bugs/6755.

Change History (6)

comment:1 by criezy, 8 years ago

I just saw that nobody commented on this bug yet, so I confirm that this is a known issue when we use SDL 1.2 on recent OS X releases. Using SDL 2 fixes that issue and I believe it is planned to switch to SDL 2 after the 1.8 release (so 1.9.0 will hopefully be OK).

comment:2 by criezy, 8 years ago

Component: Ports
Owner: set to criezy

As indicated in the previous command, the 1.9.0 release will be using SDL 2, which means this problem will hopefully be fixed. We are starting the release cycle now, so the release should be about a month from now. I am also planning to make available some test builds this weekend (probably tomorrow).

comment:3 by criezy, 8 years ago

Ticket #9559 was closed as duplicate of this one.

comment:4 by angstsmurf, 8 years ago

With the latest SDL 2 build this seems to work correctly.

comment:5 by criezy, 8 years ago

Resolution: fixed
Status: newclosed

ScummVM 1.9.0, which uses SDL 2, has now been released. I am therefore closing this bug now.

comment:6 by digitall, 6 years ago

Component: PortsPort: Mac OS X
Note: See TracTickets for help on using tickets.