Opened 4 years ago

Closed 16 months ago

#6748 closed defect (fixed)

TINSEL: Discworld II Save Naming Crash

Reported by: SF/softwarespecial Owned by: csnover
Priority: blocker Component: Engine: Tinsel
Keywords: has-save-game reproducible has-pull-request Cc:
Game: Discworld II

Description

Note When I load my save and then I try to save it crashed after imputing 17 characters. If I load the first save game and try to save it won't crash until about 20 characters. Not sure if this is a bug or something got corrupted on my end. I had saves before and I deleted them. It may be the crashing has something to do with that.

Ticket imported from: bugs/6748.

Attachments (4)

Saving On Discworld 2 type in 17 characters it crashes.avi (1.1 MB) - added by SF/softwarespecial 4 years ago.
dw2-gb.009 (2.2 KB) - added by SF/softwarespecial 4 years ago.
Error Given to me from Discworld 2.JPG (18.2 KB) - added by SF/softwarespecial 4 years ago.
Saving On Discworld 2 type in 17 characters it crashes.2.avi (1.1 MB) - added by SF/softwarespecial 4 years ago.

Change History (19)

Changed 4 years ago by SF/softwarespecial

Changed 4 years ago by SF/softwarespecial

Attachment: dw2-gb.009 added

comment:1 Changed 4 years ago by SF/softwarespecial

Using a Daily Build I got this error when trying the same thing.

comment:2 Changed 4 years ago by digitall

Summary: Discworld 2 Save issues.TINSEL: Discworld II Save Naming Crash

comment:3 Changed 4 years ago by digitall

Can't replicate this with the latest git master on Linux x86_64.

I suspect that the cause is a corrupted savegame as Tinsel has had issues in this area...

softwarespecial: I would suggest removing all the DW2 savegames and then try again from a clear start to see if this happens again?

comment:4 Changed 4 years ago by digitall

Resolution: worksforme
Status: newpending

comment:5 Changed 4 years ago by wjp

I also can't reproduce it, and valgrind shows nothing.

comment:6 Changed 4 years ago by SF/softwarespecial

I removed the old saves and still get the bug. I may try to reinstall the ScummVM first do a uninstall then a reinstall. Remember the crash doesn't happen every save but on some it will crash only after imputing a certain amount of characters. Would it help if I sent you all the saves I did?

comment:7 Changed 4 years ago by wjp

Can you describe the exact steps you take to reproduce this crash? (i.e., exactly how you launch scummvm, how you start the game, etc...)

Changed 4 years ago by SF/softwarespecial

comment:8 Changed 4 years ago by SF/softwarespecial

I start ScummVM by double clicking the desktop Icon then I load the save game Then I do some stuff in the game then I try to save it. When I type just a few letters its fine its only if I type to many. Just try loading the ScummVM and then loading the save I attached then play some then try saving a new one and type tell you have added as many characters as it can possibly have. If it does not crash try also to save over the old save game and erase the old letters then type tell you can't any more.

comment:9 Changed 3 years ago by sev-

Resolution: worksforme
Status: pendingnew

comment:10 Changed 17 months ago by csnover

Priority: normalblocker

Raising all identified crasher, hang, and memory violation bugs which I could not fully triage myself to blocker priority for the next release.

comment:11 Changed 17 months ago by csnover

Keywords: has-save-game added

comment:12 Changed 16 months ago by csnover

Owner: set to csnover

comment:13 Changed 16 months ago by csnover

Keywords: reproducible added

To reproduce this, you need at least 8 copies of the attached save game. The game appears to run out of free objects (pFreeObject is null) and so crashes with an assertion failure in AllocObject.

comment:14 Changed 16 months ago by csnover

Increasing NUM_OBJECTS fixes the crash. These save games each have 30 letters, times 8 saves, plus the objects existing already (14, apparently), ends up with two free objects available until the engine runs out. Since the save games can be up to 40 letters long, there is a need to either increase the maximum number of objects up to at least 374, or reduce the maximum length of save game names down to 26, to prevent this problem from happening again. Obviously increasing NUM_OBJECTS is trivial, I just don’t know enough about this engine at this point to know what ramifications (if any) this would have on e.g. save games.

Last edited 16 months ago by csnover (previous) (diff)

comment:15 Changed 16 months ago by csnover

Keywords: has-pull-request added
Resolution: fixed
Status: newpending

comment:16 Changed 16 months ago by dreammaster

Status: pendingclosed
Note: See TracTickets for help on using tickets.