Opened 5 years ago

Closed 3 years ago

Last modified 8 months ago

#6747 closed defect (outdated)

WIN32: Start menu recent items ignores noconsole selection

Reported by: SF/henke37_2 Owned by: sev-
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

Starting the application from the windows start menu by picking a recent item from the submenu shows the console even if the used option is the no console option.

Ticket imported from: bugs/6747.

Change History (13)

comment:1 Changed 5 years ago by SF/henke37_2

OH! The version I use is 1.7.0.

comment:2 Changed 5 years ago by digitall

Summary: Windows start menu recent items ignores noconsole selectionWIN32: Start menu recent items ignores noconsole selection

comment:3 Changed 5 years ago by digitall

henke37: Thank you for the bug report. Can you confirm what version of Windows you are running and whether you are running the stable release win32 v1.7.0 release or a development / daily build (as these always show the console)...

comment:4 Changed 5 years ago by digitall

Owner: set to Kirben

comment:5 Changed 5 years ago by digitall

Kirben: Do you see the behaviour as described?

comment:6 Changed 5 years ago by Kirben

I can't reproduce the issue under Windows 7 (SP1), 'ScummVM (noconsole)' still works fine, when started via recent items on the Start Menu.

comment:7 Changed 5 years ago by digitall

Kirben: Thanks for checking. Will set item status to pending-works-for-me, until the submitter can confirm what version of Windows they are using and their ScummVM build and we can replicate...

comment:8 Changed 5 years ago by digitall

Resolution: worksforme
Status: newpending

comment:9 Changed 5 years ago by SF/henke37_2

Sorry for being unclear about which "recent items" menu I was referring to. The one I mean is the one in the start menu that list subitems for the application. For ScummVM, that's the individual games.

I do not know how to check if it is a release version or otherwise, but I can say that the noconsole option works when not selecting a game from the start menu. Well, the console still flashes up for a moment, but it does close within seconds, leaving behind the main application window.

I use Windows 7 x64 Home Premium.

comment:10 Changed 5 years ago by digitall

henke37: Thanks for the information.

If you run "scummvm --version" at a command line, that will list the full version... or you can tell us the URL that you downloaded it from?
Was it http://www.scummvm.org/downloads/ ? i.e.
http://prdownloads.sourceforge.net/scummvm/scummvm-1.7.0-win32.exe?download

comment:11 Changed 5 years ago by SF/henke37_2

That's the exact download that I used.

comment:12 Changed 3 years ago by sev-

Owner: changed from Kirben to sev-
Resolution: worksformeoutdated
Status: pendingclosed

comment:13 Changed 8 months ago by digitall

Component: Port: Win32
Note: See TracTickets for help on using tickets.