Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6725 closed defect (fixed)

SCI: LSL5 Mac doesn't launch with MT-32 music

Reported by: SF/kq5g5 Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Leisure Suit Larry 5

Description

Using LSL5 for Macintosh Floppy ENG, game is recognized.
However, when MT-32 emulator is selected launching game pops up the console with ERROR: Failed to find MIDI command byte!

Switching audio to adlib emulator, game launches.
tested on Mac with ScummVM 1.7.0, and on the daily build 1.8.0git694-g63f2ba2 sep 3 2014. (on the daily build, resource forks were missing since they don't transfer easily to Windows)

since running the Install is a great challenge, the contents of each floppy were dragged into one folder. On the Mac, resource forks seem to have been preserved on the .drv files. (confirmed with ls -ls and derez)

Have I missed something?

Ticket imported from: bugs/6725.

Change History (11)

comment:1 by SF/mthreepwood, 5 years ago

I don't have LSL5 Mac (nor an MT-32), but it looks like it fails to load the patch (1.PAT) because it (mis)detects as an MT-32/GM patch instead of a normal MT-32 patch. (The error only happens in the former case, and the latter case should be the same for all Mac games.)

What's the size of the file?

comment:2 by SF/kq5g5, 5 years ago

On Sat, 06 Sep 2014 02:04:11 +0000, "clone2727" mthreepwood@users.sf.net
wrote:

I don't have LSL5 Mac (nor an MT-32), but it looks like it fails to load
the patch (1.PAT) because it (mis)detects as an MT-32/GM patch instead
of
a normal MT-32 patch. (The error only happens in the former case, and
the
latter case should be the same for all Mac games.)

What's the size of the file?

1.PAT is 16907 bytes.
MD5 (1.PAT) = c3318de0cd50b371c78cd115ca92a994

I'm just using the MT-32 Emulator in this case. I do have an MT-32, but
it has never been set up on the Mac.

comment:3 by digitall, 5 years ago

kq5g5: I think it would probably be best if you could attach a text file to this bug containing a file listing of your LSL5 Mac datafiles, preferably with full file md5sums?

The OSX command line "md5sum" tool will give these.

comment:4 by digitall, 5 years ago

Summary: LSL5 Mac doesn't launch with MT-32SCI: LSL5 Mac doesn't launch with MT-32 music

comment:5 by SF/mthreepwood, 5 years ago

@digitall No, that will be completely unhelpful.

I spoke with Walter about this one. The problem is a extra byte at the end of the file that throws off our detection of patch type.

comment:6 by digitall, 5 years ago

"completely unhelpful"?!

Since the user seems unclear where he has copied the files correctly, it would seem useful to ensure that they are identical to a developer who owns LSL5 Mac... but I am obviously wrong.

I could not see how you had reached the conclusion that this was due to 1.PAT when "I don't have LSL5 Mac (nor an MT-32)".

I assume you checked with waltervn, who does own LSL5 Mac and a MT-32, he tested this and it also failed for him and this is the reason?

comment:7 by SF/mthreepwood, 5 years ago

Yes.

comment:8 by digitall, 5 years ago

OK. That is clear now.

I would offer to help test as I have a MT-32, but as far as I can determine all of my SCI games are MS-DOS/Windows versions. Sorry about that.

comment:9 by SF/kq5g5, 5 years ago

Using the advanced OSX 'head' command, I gave 1.PAT an 8-bit derriere-ectomy, and tried again.

It worked!

comment:10 by bluegr, 5 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:11 by bluegr, 5 years ago

Thanks for your bug report, that was indeed an extra junk/unhandled byte in the MT-32 patch file.

Fixed in commit ae2be20a20, after speaking with waltervn. Closing as resolved.

Note: See TracTickets for help on using tickets.