Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6724 closed defect (fixed)

SCUMM: Freddi Fish 1 Crash in Russian Version

Reported by: SF/oleg_bobryshev Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Freddi Fish 1

Description

I got ScummVM for Android from the Android Market to day, to play Russian versions of the Freddi Fish games that I bought long ago from Akella. They all worked good on my old WinXP.

Freddi Fish 1 was recognized as "Updated/Windows/Russian" from the inside of ScummVM and worked for some time. Then ScummVM crashed. Ow.

I tested it myself several times, and it's always crashed in the same place - two locations left from the start, then selecting middle way. (I put save file of this location with the post).

Then I downloaded Windows version of ScummVM - 1.7.0. Same crash, but now at least I can see the error. It says:

Assertion failed: imhd, file engines/scumm/object.cpp, line 1016

Tell me, if more information needed.

Ticket imported from: bugs/6724.

Attachments (1)

Freddi 1 Saved Games.zip (43.7 KB ) - added by SF/oleg_bobryshev 5 years ago.

Download all attachments as: .zip

Change History (6)

by SF/oleg_bobryshev, 5 years ago

Attachment: Freddi 1 Saved Games.zip added

comment:1 by BenCastricum, 5 years ago

I can confirm this bug. It also happens with the Russian FF1 from Steam.

comment:2 by digitall, 5 years ago

Summary: Freddi Fish 1: ScummVM crashedSCUMM: Freddi Fish 1 Crash in Russian Version

comment:3 by digitall, 5 years ago

See https://github.com/scummvm/scummvm/pull/496

comment:4 by Kirben, 5 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:5 by Kirben, 5 years ago

This was a regression, caused by an assert been added, that wasn't actually required.

Fixed in ScummVM GiT, use the next daily snapshot of ScummVM.

Note: See TracTickets for help on using tickets.