Opened 5 years ago

Last modified 3 months ago

#6721 new defect

WME: The Kite - Overlapping bug

Reported by: raziel- Owned by: lolbot-iichan
Priority: low Component: Engine: Wintermute
Keywords: original Cc:
Game: Wintermute

Description

ScummVM 1.8.0git (Aug 24 2014 08:51:39)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG

There is an overlapping error in the drinking scene from the kitchen.
Once Masha moves or stands right beside Oleh her sprite is partly overdrawn by Oleh's.

Savegame and Screenshot attached

The Kite (Version 1.3.e/Windows/English)

AmigaOS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: bugs/6721.

Attachments (3)

thekite-win.000 (79.2 KB ) - added by raziel- 5 years ago.
The Kite (Version 1.3.e_Window_001.png (605.4 KB ) - added by raziel- 5 years ago.
save000.dsv (209.7 KB ) - added by raziel- 5 years ago.

Download all attachments as: .zip

Change History (13)

by raziel-, 5 years ago

Attachment: thekite-win.000 added

comment:1 by raziel-, 5 years ago

Added a screenshot

comment:2 by somaen, 5 years ago

Component: Engine: Wintermute
Game: Wintermute
Owner: set to somaen

comment:3 by raziel-, 5 years ago

Original game bug.

Checked with 1.3.e on windows.

by raziel-, 5 years ago

Attachment: save000.dsv added

comment:4 by raziel-, 5 years ago

Added a save from the original engine in the same room

comment:5 by lolbot-iichan, 3 months ago

Reproduced with 1.4.e both on WME 1.9.1 and ScummVM master.
Version 1.5.x is not done with Wintermute, so this bug is as-designed and present in latest game version.

Since it's not ScummVM's bug, I suggest to convert this defect to a low-priority enchancement (or normal-priority enchancement). Workaround may be possible, but would require hacking room geometry.

Last edited 3 months ago by lolbot-iichan (previous) (diff)

comment:6 by lolbot-iichan, 3 months ago

Owner: changed from somaen to raziel-
Resolution: invalid
Status: newpending

comment:7 by lolbot-iichan, 3 months ago

Returning to raziel- to decide priority.

comment:8 by raziel-, 3 months ago

I guess the comment from tobiasetan on my other The Kite bug covers this one too?

He said:
https://bugs.scummvm.org/ticket/6722#comment:8

Not yet. Looks like what we do here is

  1. Checking with the original developer if there is an updated version (or plans for one)
  2. If not, we consider adding a workaround.

So, since the original developer did not fix it, i guess we would be going for a workaround.
Then again, if the workaround means adding a "hack" i'd rather vote for it to be an entry on a wiki page which lists known original game bugs...like it's done for AGI here:
https://wiki.scummvm.org/index.php?title=AGI/TODO

...and probably add a "Will not be fixed..." or something like that?

comment:9 by lolbot-iichan, 3 months ago

Keywords: original added
Owner: changed from raziel- to lolbot-iichan
Priority: normallow

Thanks for information on Wiki! I'm still new to most project practices, so I was unaware of such TODO sections. I have requested edit access to wiki pages and will add known Wintermute original bugs (fixed, like #6572 and non-fixed, like this) to corresponding page once I'll get access.

Meanwhile I've talked to Criezy about bug types and priorities.

I will assign this to myself (since I think I know how to fix it when I'll have some time for this) as a "defect" typed bug with tag "original" (by rules for original bugs) and with priority "low" (since it's original behaviour that happens only if you move character in a specific place on specific game act).

comment:10 by lolbot-iichan, 3 months ago

Resolution: invalid
Status: pendingnew
Note: See TracTickets for help on using tickets.