Opened 5 years ago

Closed 11 days ago

#6718 closed defect (invalid)

SCI: LSL6 Polish - Engine aborts with error when "Settings" button used

Reported by: SF/paputnik Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Leisure Suit Larry 6

Description

Hi. When Im pressing the settings button, the console is showing up with an error: Unsupported flags byte (79) inside sci 1.1 view! Thats happening in polish (dos/windows) version of the game. Everything else seems to work fine. Im using latest version of ScummVM.

Ticket imported from: bugs/6718.

Attachments (3)

Clipboard01.jpg (40.6 KB ) - added by SF/paputnik 5 years ago.
res_md5.txt (9.6 KB ) - added by SF/paputnik 5 years ago.
scummvm00000.jpg (27.5 KB ) - added by SF/paputnik 5 years ago.

Download all attachments as: .zip

Change History (14)

by SF/paputnik, 5 years ago

Attachment: Clipboard01.jpg added

comment:1 by digitall, 5 years ago

Summary: LSL6 PL - Settings error consoleSCI: LSL6 Polish - Engine aborts with error when "Settings" button used

comment:2 by digitall, 5 years ago

paputnik: Please answer the following questions / requests and be clear: 1. What Operating System are you using? Windows XP 32-bit? Windows 7 64-bit? 2. What version of ScummVM are you using? v1.6.0? v1.7.0? 3. Please could you attach a text file to this bug containing a file listing of your LSL6 Polish datafiles, preferably with file md5sums? The output of a tool such as this: http://md5summer.org or other tool from http://wiki.scummvm.org/index.php/Reporting_unknown_MD5_checksums would be optimal.

This will allow us to locate a developer with your Polish variant, identify the exact version and eliminate corrupted datafiles as a cause of this problem.

by SF/paputnik, 5 years ago

Attachment: res_md5.txt added

comment:3 by SF/paputnik, 5 years ago

Im using Windows 7 64-bit (I was also trying to run the game in Windows XP 32-bit) I was checking both versions of ScummVM (1.6.0 and 1.7.0) Datafiles with md5sums attached below.

Btw. I didn't delete any windows files from the game directory. I left everything untouched after installation.

comment:4 by digitall, 5 years ago

Hmm.. That looks like a patched up LSL6 English version.

Is this a fan patch for Polish language support? Or is this one of the official Polish releases of http://www.mobygames.com/game/windows/leisure-suit-larry-collection ?

If so, which one? As that will help our SCI engine developers locate a copy to test with.

comment:5 by SF/paputnik, 5 years ago

This is the official Polish releases of Leisure Suit Larry Collection called "Leisure Suit Larry Edycja Kolekcjonerska".

comment:6 by bluegr, 5 years ago

Owner: set to bluegr
Resolution: fixed
Status: newpending

comment:7 by bluegr, 5 years ago

Thanks for reporting this

This bug should be resolved with commit 22aaf995ed, which should be available in the next daily version of ScummVM. Since I don't have this version, please tell us if everything is working as it should.

Setting this as "pending" until the bug reporter replies

by SF/paputnik, 5 years ago

Attachment: scummvm00000.jpg added

comment:8 by SF/paputnik, 5 years ago

Hi. I just downloaded the last daily build (f94f48ae) and unfortunately an error is still occureing. This time the console shows "Bad loop_pionter". I can share some files from the polish version if you would like to test it on your version of the game.

comment:9 by m-kiewitz, 5 years ago

Resolution: fixed
Status: pendingnew

comment:10 by m-kiewitz, 5 years ago

It seems a view is corrupted. Can you please post a list of the files in the directory of your game?

comment:11 by bluegr, 11 days ago

Resolution: invalid
Status: newclosed

Since this is the *only* case where this occurs, the root cause is probably corrupted game files. The original poster has not been responsive for the last 5 years, so I'm reverting the relevant commit, and closing this as invalid.

Note: See TracTickets for help on using tickets.