Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6695 closed defect (wontfix)

Script hangs at start Mordack fight

Reported by: SF/kq5g5 Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 5

Description

Tested on 1.7.0 Mac/PPC, Mac/Intel and Win7 with 1.8.0git126-g3dc9b75 built Aug 4.
King's Quest V
French Floppy version included on 1994 King's Quest Collectors Edition CD
0.000.148 in about-game, 1.000 in VERSION

After wand is recharged, pick up your wand.(sparkly one)
Mordack scene begins. After Owl is hit, three more dialogs, and then hour-glass icon appears, and action stops when first transform should occur. Music continues in loop.

Same happened in DosBox when replay attempted. However, sound card changes in dosbox got it to hang when third transform should have occurred.

Ticket imported from: bugs/6695.

Attachments (1)

kq5-fr.000 (51.8 KB ) - added by SF/kq5g5 5 years ago.

Download all attachments as: .zip

Change History (4)

by SF/kq5g5, 5 years ago

Attachment: kq5-fr.000 added

comment:1 by bluegr, 5 years ago

Owner: set to bluegr
Resolution: wontfix
Status: newclosed

comment:2 by bluegr, 5 years ago

This is a known problem with some floppy versions of KQ5, and is caused by broken/corrupt resource files. There's not much that we can do about it, I'm afraid. Your only option is to find a non-broken version (e.g. the CD version), and dump the resource files from that one to fix your broken version.

Check this page, which describes which files you'll need from a non-broken version:
http://wiki.scummvm.org/index.php/SCI/KQ5_floppy_fix

Closing

comment:3 by SF/kq5g5, 5 years ago

I tried extracting those resources from KQ5CD English, and tried them with the default file names and renamed as 146.P56-style forms as well. They did not seem to have any effect on either ScummVM or the original interpreter. There is no KQ5CD French that I am aware of.

Since the original interpreter does progress farther than the ScummVM, is it still a resource corruption? Or is it a timing bug of some kind? I notice that a previous bug 6251 sounds somewhat similar. https://sourceforge.net/p/scummvm/bugs/6251/

If not, then not too big a loss I guess. Thanks for the tip on the resources!

Note: See TracTickets for help on using tickets.