Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6689 closed defect (invalid)

SWORD1: Unable to examine and notice toilet brush used by kebab seller

Reported by: SF/jcw2 Owned by:
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

ScummVM version: 1.6.0, release.
Bug details:

Description:
Unable to look at toilet brush being used by kebab vendor. The problem is actually
just as this user has described:

http://forums.scummvm.org/viewtopic.php?t=2152

I've been to the club, seen the sign, asked Ultar to translate and gone back
to the kebab vendor. I can actually see the vendor using it but no matter where
I examine the stand, George never notices the brush.
I've also tried restarting the game and loading my save.

Language of game: English
Version of game: Talkie, CDROM version from the Broken Sword Trilogy DVD
Platform and Compiler: OSX

Ticket imported from: bugs/6689.

Attachments (1)

sword1.000 (977 bytes ) - added by SF/jcw2 5 years ago.

Download all attachments as: .zip

Change History (7)

by SF/jcw2, 5 years ago

Attachment: sword1.000 added

comment:1 by criezy, 5 years ago

Summary: Unable to examine and notice toilet brush used by kebab sellerSWORD1: Unable to examine and notice toilet brush used by kebab seller

comment:2 by criezy, 5 years ago

I don't have the exact same version of Broken Sword you have, but with your save game it works fine for me.

What you need to do:
1) Examine the kebab vendor with a right mouse button click (the mouse pointer should be a mouth as you you were to speak to him, but George should make a comment on the brush).
2) Then you can speak to Nejo about getting the brush.

Can you confirm this is what you tried to do and it didn't work?

comment:3 by SF/jcw2, 5 years ago

You are absolutely correct. It does work. Sigh.

This is of course, strange, because all through the game you never use the right mouse. When you move over an object the icon changes to a mouth, gears, etc. and the left mouse does the action. However, in this one situation only /right/ clicking when it's a mouth icon gives you a different outcome. Isn't this a bit strange or at least incredibly inconsistent for the interface? I've not used a right click anywhere in the game yet :|

comment:4 by SF/jcw2, 5 years ago

Alright, I take that back. It seems that right click does do some kind of observation of an object in some situations (but not all). Sorry for wasting your time on this and hopefully everyone else learning the hard way will see this :|

comment:5 by criezy, 5 years ago

Resolution: invalid
Status: newclosed

comment:6 by criezy, 5 years ago

You are not the only one who struggled with that part as the forum post you link to testify.

Thanks for confirming it works. Closing as invalid.

Note: See TracTickets for help on using tickets.