Opened 5 years ago

Last modified 5 years ago

#6685 new defect

GOB3 Hebrew - Right Hand doesn't respond to click

Reported by: SF/orgads Owned by:
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Goblins 3

Description

The game's version is DOS/Hebrew. Clicking the Right Hand should select it for action, but it behaves like a click on a neutral area (moves the Left Hand around).

Attached a saved game.

Ticket imported from: bugs/6685.

Attachments (1)

gob3-he.s24 (17.9 KB ) - added by SF/orgads 5 years ago.

Download all attachments as: .zip

Change History (9)

by SF/orgads, 5 years ago

Attachment: gob3-he.s24 added

comment:1 by digitall, 5 years ago

What version of ScummVM are you using? On what Operating System?

comment:2 by SF/orgads, 5 years ago

Debian sid, 1.7.0. Tested also with latest master.

comment:3 by digitall, 5 years ago

orgads: Please can you test with v1.6.0, v1.5.0 and see if this is a recent regression or if this has always been the same behaviour? Thanks.

comment:4 by digitall, 5 years ago

Replicated this with Gob3/DOS/English and the associated savegame.

This is in the Chessboard scene. It appears to be a bad game state, probably due to another script bug which is unfortunately not unusual in GOB engine:
http://wiki.scummvm.org/index.php/Gob/TODO#Script_bugs
http://wiki.scummvm.org/index.php/Gob/Bugs

orgads: Please try playing through again from an earlier savegame or from a clean new start and see if this occurs again?

comment:5 by SF/orgads, 5 years ago

It's my son who played it. He said this level is almost the end of the game, and he doesn't want to replay the whole thing again (especially when he may run into the same problem again...)

Other ideas? :)

comment:6 by digitall, 5 years ago

As I said, try loading from an earlier savegame. If he only kept a single savegame and overwrote it... well, he has learnt a valuable life lesson: Always keep backups. :)

Unfortunately GOB engine games have a large number of scripting bugs in the original and an internal design which allows for these kind of problems. They occurred in the original interpreter as well... and we do try to fix them, but it is not always easy to find the root cause and patch.

comment:7 by SF/orgads, 5 years ago

If I understood him correctly, it worked fine until he picked up the block of marble.

comment:8 by SF/orgads, 5 years ago

Ok, he started from an earlier save and it worked fine. Thanks for the tip.

Note: See TracTickets for help on using tickets.