Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6664 closed defect (fixed)

SIMON1: Music in floppy version starts only after soundeffect

Reported by: SF/apprentice-fu Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

ScummVM 1.7.0git7792-g4ebf52d (June 29 2014 05:48:24)
Tested with German and English versions.
Only the floppy versions seem to be affected.
Tested with daily build on Windows and self-compiled on Linux

The music does not start to play. Only after a soundeffect was present (in the intro: the jumping table; early in the game: the hammer on the anvil) the music starts.
If you enter a screen with different music, the music stops again.

So in the intro the music starts only after the the jumping table.
When you enter the Drunken Druid pup, the music stops. It starts to play when you pick up the matches. If you leave the pub it stops again.

Version 1.6 seems not to be affected

Ticket imported from: bugs/6664.

Change History (2)

comment:1 by Kirben, 5 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:2 by Kirben, 5 years ago

This is a gression caused by my changes in revision ac9182181d899d66ba6317e3e51dc781961ba239 when I tried to work around Roland-MT32 music issue in Simon the Sorcerer 2.

I fixed the problems, by reverting those changes. Use the next daily snapshot of ScummVM GiT.

Note: See TracTickets for help on using tickets.