Opened 5 years ago

Closed 22 months ago

#6641 closed defect (fixed)

TUCKER: Bubbles in the Plugs Shop not always visible

Reported by: raziel- Owned by: sev-
Priority: normal Component: Engine: Tucker
Keywords: Cc:
Game: Bud Tucker

Description

ScummVM 1.7.0git (Jun 11 2014 20:43:14)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG

The bubbles in the Plugs Shop should be flying out of the plug hole no matter where Bud is standing. But they don't.

They are only visible if Bud is standing near the photo booth and are erased once Bud gets near them.

Checked with the original interpreter

Bud Tucker in Double Trouble (DOS/English)

Ticket imported from: bugs/6641.

Attachments (2)

tucker.12 (333 bytes ) - added by raziel- 5 years ago.
SAVEGM.08 (2.0 KB ) - added by raziel- 5 years ago.

Download all attachments as: .zip

Change History (12)

by raziel-, 5 years ago

Attachment: tucker.12 added

comment:1 by raziel-, 5 years ago

AmigaOS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

comment:2 by digitall, 5 years ago

raziel_: Can you please attach the equivalent savegame from the original interpreter running in DOSBox to allow comparison by developers? Thanks.

comment:3 by digitall, 5 years ago

Replicated with latest Git master on Linux x86_64 with (DOS/German) variant and the attached savegame i.e. Not BE specific bug.

by raziel-, 5 years ago

Attachment: SAVEGM.08 added

comment:4 by raziel-, 5 years ago

Savegame from original interpreter played with DosBox

comment:5 by digitall, 5 years ago

I had a faint recollection of a previous bug affecting the Plug Shop Bubbles. It is here:
http://sourceforge.net/p/scummvm/bugs/5509/

This was fixed by cyx in 0bffd77dfefc33d5c6490383751f366f1b7ee0ed . However it looks like that fix was not totally correct or has suffered a regression.

raziel_: Could you try a "git checkout 0bffd77dfefc33d5c6490383751f366f1b7ee0ed; ./configure --disable-all-engines --enable-tucker && make clean && make" and then retest with this please to compare? (Note, the "--enable-tucker" rather than "--enable-engines=tucker" as this predates the fix for these commands IIRC)

comment:6 by digitall, 5 years ago

Owner: set to cyxx

comment:7 by digitall, 5 years ago

cyx: Any ideas?

Apart from this, that fix indicates the relevant code if another developer wants to take a look at this.

comment:8 by raziel-, 5 years ago

@digitall

0bffd77dfefc33d5c6490383751f366f1b7ee0ed tested.

The bubbles pop out right, but they still vanish when ego gets in their way and reappear when he moves out of their way again.

It seems as if cyx forgot about that second bug i mentioned in the old item (Thats why you always should create one item for one bug ... err, note to self) :-)

comment:9 by bonki, 23 months ago

Potential fix in PR-1119.

comment:10 by sev-, 22 months ago

Owner: changed from cyxx to sev-
Resolution: fixed
Status: newclosed

PR-1119 fixed it, now matches in original.

Note: See TracTickets for help on using tickets.