Opened 5 years ago

Last modified 4 years ago

#6630 new defect

SCUMM: MI3 - Guybrush pick up vine Animation at end of Quicksand Scene missing

Reported by: SF/andwan0 Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

The big after you get spat out by the green snake, and you are in the quick sand. When you manage to get the vine/rope to pull yourself out, your character just disappears and you hear sound effects of him pulling himself out.

Ticket imported from: bugs/6630.

Attachments (3)

The Curse Of Monkey Island (CD Windows).md5 (1.6 KB ) - added by SF/andwan0 5 years ago.
comi.s10 (105.6 KB ) - added by SF/andwan0 5 years ago.
comi.s34 (108.3 KB ) - added by eriktorbjorn 5 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 by digitall, 5 years ago

andwan0:

Firstly, please can you indicate what version of the ScummVM IOS port you are using? This is listed above the logo on the launcher screen.

If this is v1.6.0 or earlier, then please download and install the latest daily build from here and retest please:
http://buildbot.scummvm.org/builds.html

Secondly, please can you attach a savegame just before this point to allow easy replication and investigation by the developers?

Thirdly, what IOS device are you using? Please include OS version.

Fourthly, it would be useful for you to attach a text file to this bug listing your MI3 datafiles and the associated file MD5sums so we can eliminate corrupted, damaged or variant datafiles as a cause for this. The output of a tool such as http://md5summer.org/ would be optimal.

Without answers to these points, investigating this problem could be a long and painful process.. please help us here by providing this.

comment:2 by digitall, 5 years ago

Summary: iPad/iPhone port: Some animations don't appearSCUMM / IOS: MI3 - Quicksand pull out animation missing

comment:3 by SF/andwan0, 5 years ago

iOS 5.1.1 (coz it's jailbroken iPad).
my current buildbot is 1.7.0git7563-gdc4b9b8
coz I updated like 2 days ago...
and just tested again and missing animation

by SF/andwan0, 5 years ago

Attachment: comi.s10 added

comment:4 by SF/andwan0, 5 years ago

Saved game. just use the pea shooter (in your INVENTORY) to shoot the balloon.

comment:5 by digitall, 5 years ago

Replicated with the latest Git master on Linux x86_64 with the attached savegame, so this is not an IOS specific bug.

This may be an issue present in the original?

andwan0: Could you play this through to this point in the original interpreter under Win32 to get a savegame at that point please and indicate if the missing animation is present in the original.

This could also be a regression from earlier releases of ScummVM, but testing this is tricky as the savegame format for SCUMM has changed since then and thus the newer savegame is not loadable by the older ScummVM releases. Will try to get round this and/or find an older savegame from one of my COMI playtests at this point in the game.

andwan0: If you have an earlier ScummVM release savegames or remember if this worked before and at which version, this would be useful.

comment:6 by digitall, 5 years ago

Oh, P.S. I have checked the MD5sums against my COMI datafiles and these are identical, so this is not corrupted or variant datafiles.

P.P.S andwan0, please refrain from post editing comments as those changes are not notified to developers and thus will be missed.

comment:7 by digitall, 5 years ago

Summary: SCUMM / IOS: MI3 - Quicksand pull out animation missingSCUMM: MI3 - Quicksand pull out animation missing

comment:8 by digitall, 5 years ago

Have tried running the original interpreter and this crashes in various ways with sound problems / lockups. These may be related to using a later version of DirectX (CoMI shipped against DX5.0), so having trouble comparing against the original.

Have located that Boot Param 260 is just before this scene, which allows checking this animation on older versions of ScummVM without needing a savegame:
http://wiki.scummvm.org/index.php/Boot_Params#The_Curse_of_Monkey_Island

I have checked this with 0.10.0 on Win32 and this shows the same behaviour i.e. There is no animation of Guybrush pulling himself out of the quicksand. Just the vine drops, then he moves and then it changes to him moving through the jungle and arriving at the beach.

Though there may be a longer delay between him starting to pull himself out (and his sprite disappearing) and the scene change to Jungle as this is more noticable.

Overall, I suspect that this is probably a script bug in the original. We still need to compare there.

comment:9 by digitall, 5 years ago

AH. It is not a bug in the original.

Have located the issue. There is an animation "missing" of Guybrush taking up the vine with both hands, before the scene switch to the Island view.

This is missing in the latest git master, but is present in v1.6.0 and before.

There is no animation of him pulling himself out though... Will change bug name to reflect.

Will bisect to locate the regression point.

comment:10 by digitall, 5 years ago

Summary: SCUMM: MI3 - Quicksand pull out animation missingSCUMM: MI3 - Guybrush pick up vine Animation at end of Quicksand Scene missing

comment:11 by digitall, 5 years ago

Oh damn. The bug is unstable. Sometimes with the latest version, it happens i.e. the animation is missing. Sometimes, it is not. I have checked with valgrind and there appears to be no bad memory accesses (though not sure if I caught a "bad" case). When using:
./scummvm -b 260 comi

to run this from Boot Param 260, I can replicate about 25% of the time. I suspected this may be the subtitle/speech difference, (Set speech only in the GUI and then you can enable subtitles using -n switch added to command line), but this doesn't appear to be the major difference.

I suspect this is going to be a PITA to track down and may require tracing of the relevant script.

by eriktorbjorn, 5 years ago

Attachment: comi.s34 added

comment:12 by eriktorbjorn, 5 years ago

In case boot params don't quite replicate the situation, here's a savegame from right before entering the swamp that I made from replaying the game from the begining with a current Git snapshot of ScummVM. I haven't been able to reproduce it with my savegame, but it always happens for me with the savegame that was originally attached to illustrate the glitch.

comment:13 by digitall, 5 years ago

eriktorbjorn: I see the same behaviour here i.e. reliably occurs with bug submitter savegame, but not yours.

Unfortunately, loading the bug submitter's savegame on v1.6.0 and earlier is not possible due to the savegame version.

But if a SCUMM dev could compare the game script states between yours and the submitters savegame, they may be able to work out why this occurs...

Note: See TracTickets for help on using tickets.