Opened 6 years ago

Closed 5 years ago

#6576 closed defect (fixed)

WME: Rosemary - Game exit when entering the well

Reported by: SF/ignalina Owned by: somaen
Priority: normal Component: Engine: Wintermute
Keywords: Cc:
Game: Wintermute

Description

User picked target 'rosemary-win' (gameid 'wintermute')...
When trying to enter the well in osx_intel-master-85d8dc72 the game exits.

I see this in Terminal, but the warnings are probably unrelated, as they are printed at game start, not on exit:

User picked target 'rosemary-win' (gameid 'wintermute')...
Looking for a plugin supporting this gameid... Wintermute
Starting 'Wintermute engine game'
WARNING: BaseFontTT::InitFont - Couldn't load font: fonts\framd.ttf!
WARNING: BaseFontTT::InitFont - Couldn't load font: fonts\framd.ttf!
WARNING: BaseFontTT::InitFont - Couldn't load font: fonts\framd.ttf!
WARNING: BaseFontTT::InitFont - Couldn't load font: fonts\framd.ttf!
WARNING: BaseFontTT::InitFont - Couldn't load font: fonts\cambria.ttc!
WARNING: BaseFontTT::InitFont - Couldn't load font: fonts\cambria.ttc!

(Those fonts are in the game archive by the way, except that the Cambria file is named CAMBRIAB.TTF)

Save game attached. Just click on Put, Rope and Hook, then Well Bar.

I'm on OSX 10.9 Mavericks.

Ticket imported from: bugs/6576.

Attachments (1)

rosemary-win.001 (56.3 KB ) - added by SF/ignalina 6 years ago.

Download all attachments as: .zip

Change History (7)

by SF/ignalina, 6 years ago

Attachment: rosemary-win.001 added

comment:1 by SF/ignalina, 6 years ago

There seems to be a general problem with the Mac version of Scummvm not finding files in the Rosemary folder. When running Rosemary with the Windows version of Scummvm I get a startup movie and different fonts that are properly aligned. I have not played it far enough to see if this crash occurs on Windows, but according to other reports it does not.

comment:2 by SF/ignalina, 5 years ago

Okay, so this was caused by the buildbot making OS X builds without Theora and Freetype support. It works as intended when I roll my own.

It didn't really crash before either, it just ended normally after not showing the ending movie.

comment:3 by somaen, 5 years ago

So, this is resolved as long as Theora support is compiled in?

comment:4 by somaen, 5 years ago

Owner: set to somaen

comment:5 by SF/ignalina, 5 years ago

Yes, fixed, thanks. And now it prints a warning if there is no Theora support as well.

comment:6 by somaen, 5 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.