Opened 6 years ago

Closed 3 months ago

#6570 closed defect (fixed)

WME: Save thumbnails are black

Reported by: raziel- Owned by: somaen
Priority: normal Component: Engine: Wintermute
Keywords: Cc:
Game: Wintermute

Description

ScummVM 1.7.0git (Apr 8 2014 10:05:38)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG

Save thumbnails appear black in the launcher.
Probably not implemented yet?

Rosemary (Windows/English)
AmigaOS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: bugs/6570.

Attachments (6)

rosemary-win.001 (62.3 KB ) - added by raziel- 6 years ago.
deadcity-win.003 (19.3 KB ) - added by albadross 3 years ago.
thekite-win.003 (49.5 KB ) - added by albadross 3 years ago.
wmeunk-WhiteChamber-win.003 (54.1 KB ) - added by albadross 3 years ago.
carolreed4-win.003 (102.2 KB ) - added by albadross 3 years ago.
Corrosion thumbnails.png (359.5 KB ) - added by albadross 3 years ago.

Download all attachments as: .zip

Change History (23)

by raziel-, 6 years ago

Attachment: rosemary-win.001 added

comment:1 by somaen, 5 years ago

Owner: set to somaen

by albadross, 3 years ago

Attachment: deadcity-win.003 added

by albadross, 3 years ago

Attachment: thekite-win.003 added

by albadross, 3 years ago

Attachment: wmeunk-WhiteChamber-win.003 added

by albadross, 3 years ago

Attachment: carolreed4-win.003 added

comment:2 by albadross, 3 years ago

Black thumbnails also appear in the Windows/English versions of:

  • Dead City
  • The Kite
  • The White Chamber

run on ScummVM 1.9.0git6805-g1d816d6 (Sep 23 2016 04:19:58)

On the positive side, I do get the correct picture thumbnails on :

  • all 8 Carol Reed mysteries
  • 5 Magical Amulets, 5 Lethal Demons
  • Dirty Split
  • Pigeons in the Park
  • Helga Deep In Trouble (the only one I haven't completed)

comment:3 by somaen, 3 years ago

Resolution: fixed
Status: newpending

I guess what most of the problem games might have in common, is the lack of thumbnail-based save/load in-game, at least Dead City never set a thumbnail-size, which led to the engine-default of 0 being used. I've now changed the engine-default so that we should get thumbnails for most games hopefully. (But this might not necessarily give perfect results in all cases)

Would you mind retesting with a new version? (Old saves will not have thumbs as they were never stored into the savegame, but subsequent saves should get them)

comment:4 by raziel-, 3 years ago

Checked with a fresh build and (thanks to albadross for the other games)
Rosemary
Dead City
and The Kite
are fixed.

Carol Reed 4 i can't check as i don't have that, then again in albadross' summary the game is marked as not affected (see above "All 8 Carol Reed mysteries have the correct thumbnail picture"), so i guess it was a mistake that this save state was added(?)

In any way for me it's fixed

Thanks a lot somaen

comment:5 by albadross, 3 years ago

I have confirmed the fix by re-saving the games on the latest Windows build and the thumbnails now show.

Other Wintermute games which exhibited the same problem but are also fixed :
Escape from the Mansion
The White Chamber

comment:6 by raziel-, 3 years ago

Corrosion: Cold Winter waiting has still the issue of save thumbnails being black

comment:7 by albadross, 3 years ago

My Corrosion thumbnails are OK - ScummVM 1.10.0git215-gd09c49f (Oct 8 2016 05:17:20).

I have attached a png showing this.

I have completed the game in the last couple of days and the thumbnails show throughout (all 97 of them!)

Last edited 3 years ago by albadross (previous) (diff)

by albadross, 3 years ago

Attachment: Corrosion thumbnails.png added

comment:8 by raziel-, 3 years ago

I believe you, but as you were writing here:
http://forums.scummvm.org/viewtopic.php?t=13062&start=68

you are using the enhanced edition which may be why it's fixed for you.

I only have the normal edition you can't buy anymore

I wonder if i should enter a new bug item?
Devs?

comment:9 by bonki, 16 months ago

Resolution: fixed
Status: pendingnew
Summary: WME: Rosemary - Save thumbnails are blackWME: Save thumbnails are black

I can reproduce this with current master, Corrosion savegames created via the in-game save dialog are still black.

comment:10 by digitall, 12 months ago

bonki: There is apparently a demo for this game, but I can't locate a working link online for this. If that is available, then hopefully could replicate with that and investigate so this bug can get closed out...

comment:11 by raziel-, 12 months ago

@digitall

I'm not sure about that there actually exists a demo version...it rather looks like as if some "demo" exe's implements a 20-30 minute timer until the game stops, but with a fully playable .dcp (at least thats what i think when i checked one of those "demos").
The .dcp is marginally smaller than the one i got with my download code (might be a newer/older version though).

comment:12 by lolbot-iichan, 3 months ago

Owner: changed from somaen to raziel-
Resolution: fixed
Status: newpending

I can reproduce this! Corrosion savegames created via the in-game save dialog still have black screenshots, both for Enchanced and Normal editions, savegames created with Ctrl+F5 menu have good screenshots, both for Enchanced and Normal editions.

I believe this is by-design game scripts behariour, not ScummVM bug. Reasons:

  1. Corrosion fades to black before entering menu, so it's highly possible that black screenshot is an actual screenshot of blackness that is rendered below ingame menu
  2. Corrosion does not have in-game savegame preview, so developers might have had the same issues with black screenshots and removed them from UI for that reason. Or maybe not.
  3. Somaen fixed all-by-one games by simply setting engine-default thumbnail size to non-zero.

So, I suggest to close this as fixed by Somaen, and open a new low-priority enchancement (or normal-priority enchancement) request for a Corrosion-only hack that would fix that somehow.

Last edited 3 months ago by lolbot-iichan (previous) (diff)

comment:13 by lolbot-iichan, 3 months ago

Returning to raziel- to decide priority.

comment:14 by raziel-, 3 months ago

Oh...but i'm just the reporter.

I'll accept whatever you devs think is best for resolving this issue.
Even if that would mean it gets closed as invalid and the game not having any thumbnail preview.

You explained already why there are no thumbnails and imho every "hack" to the code is one too many :-)

So, on my vote, go ahead with your suggestions, they are fine by me.

Last edited 3 months ago by raziel- (previous) (diff)

comment:15 by lolbot-iichan, 3 months ago

Ok, as for me, there should be two bugs:

  1. this one, describing issues with different games that have engine-default thumbnail size equal to zero, which we should mark as fixed and owned by somaen, since he fixed it 3 years ago
  2. new one ("enchancement"/"original"/"normal"), describing Corrosion-specific issue, that actually seems to me as a good enchancement that will really improve user experience, since ScummVM's load menu have screenshots for all other games, but also a original game bug that should be listed at Wiki

As you were original reported of issues with Corrosion at comment 6, could you please create a separate bug item for this issue? You can just copy relevant information from this item.

Last edited 3 months ago by lolbot-iichan (previous) (diff)

comment:16 by raziel-, 3 months ago

Will do once i get back home.

Thank you very much for the work on wme

comment:17 by raziel-, 3 months ago

Owner: changed from raziel- to somaen
Status: pendingclosed

In favour of continuing the Corrosion specific issue, an enhancement request was branched from this report.
See https://bugs.scummvm.org/ticket/11032 for it.

I'm closing this item like you describe.

Thank you

Note: See TracTickets for help on using tickets.