Opened 7 years ago

Closed 7 years ago

#6556 closed defect (fixed)

RINGWORLD2: Wrong mouse cursor in desert

Reported by: eriktorbjorn Owned by: dreammaster
Priority: normal Component: Engine: TsAGE
Version: Keywords:
Cc: Game: Return to Ringworld

Description

When walking beween two desert rooms, the screen fades down to black and the cursor disappears for a moment. If, during that blackout, I move the mouse upwards, the cursor remains the same. This may not sound so bad, but it makes it possible to have the mouse cursor a the top of the window, yet the cursor is a down arrow rather than an up one. If I click at this point, the game crashes.

A less serious consequence is that if the bad cursor is the walk cursor instead, it's possible to walk Quinn straight into the clouds.

Ticket imported from: bugs/6556.

Attachments (2)

ringworld2-cd.026 (14.5 KB ) - added by eriktorbjorn 7 years ago.
0003.SAV (15.5 KB ) - added by eriktorbjorn 7 years ago.

Download all attachments as: .zip

Change History (5)

by eriktorbjorn, 7 years ago

Attachment: ringworld2-cd.026 added

comment:1 by digitall, 7 years ago

I can also replicate the walk into the clouds with the attached savegame.

by eriktorbjorn, 7 years ago

Attachment: 0003.SAV added

comment:2 by eriktorbjorn, 7 years ago

Here's an original savegame in the desert. As in ScummVM, the cursor only changes to directional arrows for the lower half of the screen, but I can't reproduce either of the bugs in DOSBox.

comment:3 by dreammaster, 7 years ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.