Opened 6 years ago

Closed 2 years ago

Last modified 12 months ago

#6555 closed defect (fixed)

ANDROID: cursor jumps to corner

Reported by: SF/carquinyoli Owned by: fuzzie
Priority: normal Component: Port: Android
Keywords: Cc:
Game:

Description

I'm using the last daily build, ScummCm 1.7.0gi t6257-ga3575d1 (Mar 22 2014), on a tablet (a BQ Edison 2 on Android 4.2). I can move the cursor as intended, but as soon as I stop touching the cursor jumps to the upper left corner. This happens both with touchscreen and touchpad modes, and conversely, I haven't experienced any problem with the version on googleplay (1.4, I think).

Ticket imported from: bugs/6555.

Change History (14)

comment:1 by digitall, 6 years ago

Summary: Android: cursor jumps to cornerANDROID: cursor jumps to corner

comment:2 by digitall, 6 years ago

@Marc: Thank you for the bug report.

The latest current version on the Google Play store is v1.5.0:
https://play.google.com/store/apps/details?id=org.scummvm.scummvm

However, the current stable release is v1.6.0, but this is not yet released on the store for... reasons. See here for background:
http://forums.scummvm.org/viewtopic.php?t=12624

If you can test with v1.5.0 from the Store, v1.6.0 from the buildbot (stable) and the latest v1.7.0git from the buildbot (development), then this will help localise the issue/regression:
http://buildbot.scummvm.org/builds.html

Please see the notes and instructions on installing daily builds, especially the need to remove all previous ScummVM versions including plugins before installing another build:
http://wiki.scummvm.org/index.php/Android#Installation

comment:3 by SF/carquinyoli, 6 years ago

I tried both daily builds, stable and development, after uninstalling
previous versions and deleting data. Both of them have the cursor jumping
to the corner issue. After installing the google play version again, I can
move the cursor normally. Thus, it appears that the problem originated
between 1.5 and 1.6.

Thank you.
El 25/03/2014 17:43, "digitall" tdhs@users.sf.net escribió:

@Marc: Thank you for the bug report.

The latest current version on the Google Play store is v1.5.0:
https://play.google.com/store/apps/details?id=org.scummvm.scummvm

However, the current stable release is v1.6.0, but this is not yet
released on the store for... reasons. See here for background:
http://forums.scummvm.org/viewtopic.php?t=12624

If you can test with v1.5.0 from the Store, v1.6.0 from the buildbot
(stable) and the latest v1.7.0git from the buildbot (development), then
this will help localise the issue/regression:
http://buildbot.scummvm.org/builds.html

Please see the notes and instructions on installing daily builds,
especially the need to remove all previous ScummVM versions including
plugins before installing another build:
http://wiki.scummvm.org/index.php/Android#Installation


Status: open
Group: Ports
Labels: android
Created: Sun Mar 23, 2014 10:28 AM UTC by Marc
Last Updated: Tue Mar 25, 2014 04:39 PM UTC
Owner: nobody

I'm using the last daily build, ScummCm 1.7.0gi t6257-ga3575d1 (Mar 22
2014), on a tablet (a BQ Edison 2 on Android 4.2). I can move the cursor as
intended, but as soon as I stop touching the cursor jumps to the upper left
corner. This happens both with touchscreen and touchpad modes, and
conversely, I haven't experienced any problem with the version on
googleplay (1.4, I think).


Sent from sourceforge.net because you indicated interest in
https://sourceforge.net/p/scummvm/bugs/6555/

To unsubscribe from further messages, please visit
https://sourceforge.net/auth/subscriptions/

comment:4 by digitall, 6 years ago

@Marc: Please don't quote the last message like that. It is annoying and makes the artifact hard to read. I assume you replied via e-mail, if so, please don't include the previous in the reply...

It is very hard to work out exactly where the issue is, without being able to replicate this. It does not happen on my Android device, nor any of the other porters, so we will need you to be able to locate the regressive commit... or at least narrow the change range down.

If you can setup the Android build toolchain and get our code as per:
http://wiki.scummvm.org/index.php/Developer_Central#Getting_started
http://wiki.scummvm.org/index.php/Compiling_ScummVM/Android

Then you can use Git to do a bisection between v1.4.1 and v1.5.0 tags (git bisect start; git checkout v1.4.1; git bisect good; git checkout v1.5.0; git bisect bad; Loop on Compile-Test-"git bisect bad/good" until the tool emits "the first bad commit is...")

If you can't do this, I could look at doing a sloooww bisection with you, but this could take a few weeks to do, compared to you compiling yourself as I would have to compile a version, send it to you for test, you tell me good or bad... and repeat 10-12 times :/

comment:5 by digitall, 5 years ago

As the user is not responsive, there have been no other reports of this issue and replication is not possible, I think we will have to close this bug as works-for-me.

For now, I will set this to pending (waiting for an update/response from the submitter). If no further update is done within 14 days, it will be automatically closed.

comment:6 by digitall, 5 years ago

Resolution: worksforme
Status: newpending

comment:7 by SF/moraleda, 5 years ago

I have exactly the same problem since I updated yesterday to 1.7 version at google play. It´s not possible to play games because the cursor jumps to the upper left corner when I touch the screen. This did not happen before updating.

I have the same tablet BQ Edison 2 with android 4.2.2.

comment:8 by SF/rldml2010, 5 years ago

Same with me: v1.7 installed via google play market, Android 4.2.2 in use, not rooted or something like that.

The device is a Trekstor 10" VT10416-2, FW V01.00.14.

Please let me know, if I can give you any further information or test something for you to help to find the bug.

The behavior appears in direct and touchpad mode. The touchpadmode is unusable. In the directmode you can use the rightclick on a multitouch-device, because the cursor stays at the spot you point on the touch-surface as long as you touch it. If you try a leftklick, the cursor jumps directly back to the upper left corner.

Thank you for support!

comment:9 by SF/feyd80, 5 years ago

I have nearly the same bug on my tablet (Arnova 97G4 running Android 4.1.1) except the cursor does not go on the top left corner but at the point where I release my finger.

No bug on phone (HTC desire S running Android 4.0.4).

comment:10 by fuzzie, 5 years ago

This is probably caused by devices generating invalid hover/mouse events. There's a (signed) build at http://fuzzie.org/scummvm-1.7.0-nomousesupport.apk which disables mouse support; if your problems are caused by invalid mouse events, that should fix it.

comment:11 by fuzzie, 5 years ago

Owner: set to fuzzie
Resolution: worksforme
Status: pendingnew

comment:12 by SF/rldml2010, 5 years ago

That works for me.

Great Support and thank you :)

comment:13 by dafioram, 2 years ago

Resolution: fixed
Status: newclosed

comment:14 by digitall, 12 months ago

Component: PortsPort: Android
Note: See TracTickets for help on using tickets.